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1 Overview

IPMIView (IPMI-Over-LAN) is a management software program based on the IPMI specification
Reversion 1.5 - 2.0. IPMIView sends IPMI messages to and from the BMC (Base Management Card) on a
host system at a remote location. IPMI messages are encapsulated in RMCP (Remote Management
Control Protocol) packets called “datagrams.” This method is also referred to as “IPMI-over-LAN.”

According to the Distributed Management Task Force (DMTF) specification, RMCP is used for system
management in a pre-OS or an OS-absent environment. RMCP is a simple request-response protocol
that can be delivered using UDP (User Datagram Protocol) datagrams. IPMI-over-LAN uses version 1 of
the RMCP protocol and packet format. An RMCP packet is transmitted via an IP (Internet Protocol)
network, which allows system managers to manage their IPMI-enabled systems over the Internet. In a
private LAN network, this is a basic feature. IPMI uses the same UDP port number (623 in decimal) as
the ASF (Alert Standard Forum) protocol. If the managed system is protected by a firewall, UDP port 623
must be opened.

In Supermicro’s IPMI solution, a BMC (Baseboard Management Controller) shares the LAN1 NIC on the
mainboard. (If there are more than one LAN ports on the mainboard, LAN1 is the one closest to the
Keyboard/Mouse port.) The NIC will re-route the IPMI packet to the BMC instead of forwarding it to the
upper layer of the network protocol stacks as other protocol packets do.

IPMIView V2.0 covers Supermicro’s BMCs for both IPMI v1.5 and IPMI v2.0. However, due to design
changes, some functions may not be available for IPMI v1.5, while others might no longer be available
for IPMI v2.0. IPMIView will automatically hide any functions that are not available based on the BMC
version used in the system.
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2 System Management

Menu Bar —} File Edit Session Manage Help

Toolbar——ﬂ@ @ ‘I__E] 6 Q @ ko
| SUPERMICR. & 192168.1.38

IPMI Sorting — Bl IPMIDomain & ¥ @ & &

=) 192.168.1.168 System Name 192.168.1.38
) =) 192168.1.227
System List —& 1921631.38

=) New System1 IP Address 192.168.1.38
) New System2
M Description  DESCRIPTION

LoginID | ADMIN

Password | *****

System View Sessions

save |D and Password

Viewing Window

CONNECTED

Group Management — =

Version : IPM| 2.0 RMCP+
Cipher Suite : RAKP-HMAC-SHA1, HMAC-SHA1-96, AES-CBC-128

Bottom Toolbar L Login | Event Log| Sensors ||IPMI Device | BMC Setting|| Users | Text Console | KVM Console

P;!MCF‘# Open Session successful

Figure 2-1

e Menu Bar: contains functions that allow you to add/delete systems or groups and save
configurations.

e Toolbar: contains functions that allow you to execute commands quickly. Click the icons on the
toolbar to add a new system, save the current configuration settings, to discover IPMI devices, to
access group management, to discontinue the IPMIView section and to access the help menus. See
Figure 2-2 for details.

e Logo: Click the Logo icon to visit Supermicro’s website.

e IPMI Sorting: This allows you to sort devices in ascending/descending order via the online format,
or in their original sequence.

e System List: This lists the computers managed by the BMC Controller.

e Group Management: This allows the user to manage system groups, including creating/adding new
accounts, deleting accounts and updating group information.

e Group List: This lists the computer groups managed by the BMC for better management.
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e Viewing Window: This shows detailed information including Login, IPMI Device, Event Log, Sensors,
BMC Settings, and the status of the IPMIView firmware.

e System View Sessions: IPMIView can manage up to 20 systems at any given time. The systems that
are currently managed by the BMC are indicated in the System View window.

e Bottom Toolbar: This toolbar contains function tabs that allow you to execute commands quickly.
The tabs allow you to access the following submenus: Login, Event Log, Sensors, IPMI Device, BMC

Setting, Users, Text Console, and KVM Console.

As shown in Figure 2-1, there are several components in the IPMIView window (Figure 2-2):

:‘_ IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.
File Edit Manage Help

BE e @E @R
SUPERMICR®

IPMIDomain 4 ¥ Q £t @

) 192.168.10.243

IPMI View

Intelligent Platform Management Interface

IPMI 2.0/1.5 over LAN

155! Groups B & & @,
{0 IPMI Domain (4/4)

Ready

Figure 2-2

e ToolBar (Top)

The toolbar provides you with direct access to the features that are used frequently (as shown in Figure
2-3). You are able to switch between server- and group- management. The following toolbar shows the
items that are currently available for user configuration under BMC management.
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Add a new System
Save configuration

Discover IPMI device

Switch to server management

Switch to group management

|
DB LG0T R0

Close session

Show trap info
About

Figure 2-3

e Adding a new system

8 Edit Session Manage Help

System
Discover IPMI Device Group

Reload Configuration

Save Configuration CR. I

Update Firmware R
vQO &%
Language | X

Exit

Figure 2-4

Click File> New> System to add a new system to the IPMI connection (as shown in Figure 2-4). An “Add
a new system...” dialog box will display as shown in Figure 2-5.
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4 Add a new system...

IP address: ‘ 0.000

Description: ;DESCRIPTION

Figure 2-5

In the “Add a new system” dialog box, enter the System Name for the system to be managed by the
BMC, its IP address, and its description. Then click OK.

e Adding a new group

For better system management, the manager may group systems into different groups. A system may
be included in multiple groups. The default group is the “IPMI Domain.” All systems under BMC
management belong to the IPMI Domain even if they are also added to other groups.

Click File> New...> Group to add a new group to the IPMI connection.

An “Add a new group” dialog box will display as shown in Figure 2-6.

2 Add a new group E]@

Grove Nare: | [ETEES]

Descrition: | DESCRIPTION

Figure 2-6

In the “Add a new group” dialog box, enter the Group Name and its description. Then click OK.

e Discover IPMI Device

IPMIView offers a feature that will detect all devices or systems currently connected to the network. The
user may specify a Network IP address range and network Mask, then click Detect or Start to search for
any IPMI devices or systems that are connected to the IPMI 1.5 or IPMI 2.0 connections as shown in
Figure 2-7. Click Exit to discontinue this process.
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£ [PMI Deyice Discoyering. @

To | 192.168.10.25¢

Metwrork Mask | 255 285 255.0

Search Option

[Flipmizo [C]iPmias

Start Exit

Found: 2

P Idame “ersion
19216810241 19216810241 Pt 2.0 |
19216810246 19216810246 Pt 2.0 |

Figure 2-7

¢ Reload Configuration

From the pull-down menu, click File> Reload Configuration to load the configuration settings that were
previously saved.

e Save Configuration

From the pull-down menu, click File> Save Configuration to save the current configuration settings.

e Update Firmware

From the pull-down menu, click File> Update Firmware, and select the system you wish to update from
the IPMI Domain list on the left side of the window. A Confirmation dialogue box will appear. Click OK to
update the IPMI Firmware. Click Cancel to discontinue this process.

From the pull-down menu, click File> Save Configuration to save the current IPMIView configuration
settings.

e Language

From the pull-down menu, click File> Language to activate a Language submenu. From the submenu,
you can select Chinese (Traditional), Chinese (Simplified) or English as your IPMI language setting.

6 Note: There may be Chinese display issues in some Linux systems that lack Chinese fonts
for JVM. You can install Chinese fonts, e.g., SimSun.ttf, and then type the following

commands: mkfontscale, mkfontdir and fc-cache —-fv atthe font path to fix

the issue.
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e Exit

From the pull-down menu, click File> Exit or press <Alt-F4> to exit IPMIView.

¢ Modify System
Select a system in the System Window you want to modify and click Edit> Modify System to modify it

from the pull-down menu as shown in Figure 2-8.

You can also right click on a system in the System Window and select Modify in the pop-up menu to
modify it.

e Modify Group

Select a group in the Group Window you want to modify and click Edit> Modify...> Group from the pull-

down menu shown in Figure 2-8 to modify it.

You can also right-click a group in the Group Window and select Modify in the pop-up menu to modify
it.

File Sesdon  Manage Help

Mtllijf}f » = ﬁ
D gy | 52

IEMI Security Gromp | |] [ 192168102
S ICR®

Digoin
Eefrezh

v 9 @

=] 152 1A5.10.247
| 192.166.10.243

Figure 2-8

o Delete System
Select a system in the System Window you want to delete and click Edit> Delete System from the pull-

down menu as shown in Figure 2-8 to delete it.

You can also right click on a system in the System Window, and select Delete in the pop-up menu to
delete it.

e Delete Group
Select a group in the System Window you want to delete and click Edit> Delete Group from the pull-

down menu to delete it as shown in Figure 2-8.

You can also right click a group in the System Window, and select Delete in the pop-up menu to delete
it.
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e IPMI Security

From the pull-down menu, click Edit> IPMI Security to activate the IPMI Security dialogue box. Check
Auto Detection for IPMIView to automatically check the current IPMI status. Check the For Advanced
User box to select the following protocols as shown in Figure 2-9.

Hardware: BMCB, Firmware: IPMI 1.5:
Hardware: BMC2, Firmware: IPMI 2.0 (non-RMCP+):
Hardware: BMC2, Firmware: IPMI 2.0 (Standard RMCP+).

Check the Encryptor box to use encryption supported by the IPMI 2.0 Standard RMCP+. All packets
transmitted from IPMIView to the BMC system management will be encrypted.

r N

IPMI Protocol X
9 IPMI Pratocol for Mew Systemi
\_.

(7 Auta Detection
For &dvanced User. Select Following Pratocaols based on HWwW and P
() Hw' : BMCB, P IPMI 1.5
) H: BME2, Py IPMI 2.0 non-RMCP+
(%) Hw' : BMCZ, Fu : IPK] 2.0 Standard RMCP+

Encryplio
Hw = Hardware
P = Firmware

Figure 2-9

e Joina Group

Select a group in the Group window, a system in the System Window, and click Edit> Join from the pull-
down menu to include (to join) this system into the group as shown in Figure 2-8.

e Disjoin a System or a Group

Double click the group from which you want to disjoin a system. The systems that are included in the
group will appear in the System Window. Then, select the system you want to disjoin from the group,
and click Edit> Disjoin from the pull-down menu shown in Figure 2-8. You can also select a group from
the Groups list and click Edit> Disjoin to remove it from the IPMI groups.

You can also right click the selected system, and select Disjoin in the pop-up menu to remove it from the

group.
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e Refresh

Double-click the group from which you want to disjoin a system. The systems that are included in the
group will appear in the System Window. Select the system you want to refresh, and click Edit> Refresh
from the pull-down menu to refresh the system as shown in Figure 2-8.

e Timeout

The timeout setting is shown in Figure 2-10. Timeout is the period for IPMIView to wait for a response
after sending a command to a managed system. If a response is not received from the managed system
in the timeout period, IPMIView will resend the command to managed system again. You may specify
the timeout value (in seconds) to get a quicker response from the managed system. You can also specify
the number of times that IPMIView will resend the command.

Setting

»  Timmeout for retry [secundﬂ g |
\:‘f) MHumber of retry |2D |

(0] 4 Cancel

Figure 2-10

e Section

IPMIView will display the IP address(es) currently connected to the network when you click Section from
the toolbar. You can disconnect the IPMI connection from a system currently connected to the network
by clicking Closing. (the IP Address).

Ay | prees EN ) 2 @ h

Group

Setting... | .
SUPEKNVICR®
B PMiDOmain A v Q £ @
=) New Systeml |
=) 192.168.1.227

=) New System2

=) 192.168.1.168

& 1521687138

1PMI View

Intelligent Platform Management Interface

IPMI 2.0/1.5 over LAN

E Groups B&&2

Figure 2-11
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e IPMIView Management

IPMIView allows you to manage your server or your network group by selecting Manage> Server/Group
from the pull-down menu as shown in Figure 2-11.

In addition, you can also configure Group Login Settings by selecting Setting from a pull-down menu
under the Manage tab. A dialog box will appear, prompting you for the Login ID and Password. Once
enter the values in these fields, click OK to access the page and configure the settings. Please note that
this feature is available for the system administrator only.

e Help

Select About to display the information on the systems connected to the network.
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3 Login

e Login

Click the Login tab on the bottom toolbar as shown in Figure 3-1. A login screen along with some
information about the managed system will appear in the Viewing Window. Enter the login ID and
password, and click the Login button to log in. When login is successful, the connection information will
be shown at the bottom. The Login button is grayed (disabled), and the Logout button as well as other
available management functions will be enabled as shown in Figure 3-2.

E PMIView 2.21.0 (build 220915) - Super Micre Computer, Inc — [m]

File Edit Session Manage Help

BEagnd Re

4
J BN 101471607 - £12DPT

@

SUPERMIC

Systemn Name 10.147.160.7 - ¥12DPT

IPMI Domain =~ 4 + 3 £
® IP Addess 10.147.160.7

Deseription  DESCRIPTION

LoginID | EESIEHG

) 10147 33 34 - Devek Test Machine

ZJJ 10.165.54.154 Paszvond GOS0 ®
EJ 10.135.15.208

EJI 10.163.55.117 B save [D and Password
=] 10.163.55.148 [ o= SMC RAKP

) 10.163.55.53 - HIZEEW
) 10.163.55.51 - K125PE
) 1016355151 - H128P4 Login Logout
=) 10.163.55.149 - X128P0
) 10.163.55.166 - X12GCH+
) 10.163.55.182 - X133P4
) 10.163.55.188 - X123F1

T

i IFMI Domadn (6/46)
Demo (242)

.Ready

Figure 3-1
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File Edit Session Manage Help

e aade Re

4
1 BN 10.147.160.7 - X12DPT

]

SUPERMIC

Svstem Name 101471607 - X12DPT

IPMI Domain 4 ¥ 9 £
I= % IP &ddress 10.147.1607

= 1014733134 - R10DRFR

& 101471602

09 10.146.125 87 Description  DESCRIPTION
- 108LE-DF

Login[D | ADMIN

Possvorl | @000
10.135.15.208
10163.55.117 @ sve ID and Password
10.163.55.148 [ use SMC RAKP
10163.55 52 - H1288W
10163.55 51 - T128P2
10.163.55.151 - K125P4 gz Logout
10.163.55.143 - 125F0
1016355166 - T120CH+
10163.55.182 - K125P4
1 10163.55 188 - X128P1 CONNECTED

Version : [PMI 2.0 RMCP+
Cipher Suite : RAKP-HMAC-SHAL, HMAC-SHAL-96, AES-CBC-128

Login EventLog Sensors [FMIDevice BMC Setting Users Text Console  KVM Console

RMCP+ Open Session successful

Figure 3-2

In IPMIView, an MD5 algorithm will encrypt the password when it is transmitted through the network.
(If you are connecting to the IPMI 2.0 RMCP+, all the data will be transmitted by an encrypted
algorithm.) Once the password is confirmed, IPMIView will show a CONNECTED symbol, and all available
function pages will be shown as in Figure 3-2. If the password is invalid, a message will be displayed in
the Status Area that reads, “Unable to activate a session, please check ID and Password.” and a Break
symbol will be shown (see Figure 3-3).
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BN PMIView 2.21.0 (build 220915) - Super Micro Computer, Inc - ]

File Edit Session Manage Help

hleBE e R e

4
4 WM 10.147.160.7 - X12DET

]

SUPERMIC

Svstem Name 101471607 - X12DPT

il IPMI Domain =~ & + § £
I= % IP &ddress 10.147.1607

) 10.147.33134 - X10DRFR
& 10.147.160.2

Descripion  DESCRIPTION

Login D [admin
] 10.163.54.154 e YY1 1)
) 10.135.15.208
) 10.163.55.117 8 save 1D and Password
) 10.163.55.148 (] se SMC RAKF

=) 10.163.55 53 - H1288W
2] 10.163.55.51 - X125PZ
] 10.163.55 151 - K148P4 Login Logout
] 10.163.55 143 - K123P0

) 10.163.55 168 - K12QCH

=) 10.163.55.183 - X125P4
] 10.163.55 188 - K128P1 SEEAK '

RAKP Mesmge 2 erorUnauthorized name (statos code = 0Dh)
Figure 3-3

In order to reduce overhead on the managed system, all pages will not be refreshed automatically. The

user must refresh the pages manually as needed.

After logging in, the IPMIView main window will display as shown in Figure 3-2. A tool bar will display on
the bottom of the screen for your convenience.

o Note: SMC RAKP should be enabled in IPMIView only if the connection to BMC has

already enabled SMC RAKP, otherwise the connection will fail.
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e Bottom ToolBar

As shown in Figure 2-4 below, this toolbar contains function tabs to allow you to execute commands

quickly. The tabs allow you to access the following submenus: Login, Event Log, Sensors, IPMI Device,
BMC Setting, Users, Text Console and KVM Console.

Log

Event Log
Sensors

'P’\|’" Device  pyic setting

|
Login \ Event Log|| Sensors | IPMI Device | EMC Setting | Users || Test Console | KvM Console)

Users

Text Console
KVM Console
Figure 3-4
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4 Event Log

After you have logged into a system, the screen as shown in Figure 4-1 will display. Click the Event Log
tab on the bottom toolbar to activate the Event Log screen as shown in Figure 4-2.

{build 070927) - Super Micro Compnter,

Fi: Edit Session Manage Help

SN =TEIC IR
SUPERMICR®

IPMIDomain =~ 4 v @ & &
192.168.10.240

System Name 192.168.10.341
=] 192 160.10.242

7l 192.166.10.243 IP Address 102168 10241
Description 192.168.10.241

LoginID __ADMIN
R —

save ID and Passwond
Login

Groups
TPMI Domein (44}

ersion : IPMI 2.0 RMCP+

Cighex Suife : RAKP-HMAC-SHA!, HMAC-SHAI-96, ARS-CBC-128

Login | Event Log | Sensors | IPMIDevice | BMC Setting | Tsers | Text Console | KM Console | Virtual Media,
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Get: Click this button to retrieve event logs.

Refresh: Click this button to refresh SEL information.

Save: Click this button to save table event logs to a file.

Delete: Click this button to delete event logs.

Health event: Select this radio button to display the health event log.

Maintenance event: Select this radio button to display the maintenance event log..

All: Click this radio button to show all events.

From: Click this radio box to select a range of health events.

Current SEL Device Timestamp: This item displays the timestamp of the current SEL device.

To learn about the rules, hover on the information icon 0 .
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5 Sensors

There are two sensor display modes supported with IPMIView 2.20.0 and later versions. Click the right-
top combo box to switch between two modes as shown in Figure 5-1. The Graphic view is the default
display mode. Alternatively, users can still switch to text view if preferred.

! 10.147 160 14 - X12DPT

Graphic view ~

Graphic view

Fans

Figure 5-1

5.1 Graphic View

This feature displays the status of each sensor used to monitor system health, as shown in Figure 5-2.
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Figure 5-2

e Fans: This window displays fan status.

e Voltages: This window displays voltage readings for various devices.
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o Temperatures: This window displays temperature readings for various devices.

e Sensors: This window displays the devices being monitored.

e PSU: This window includes three tabs: PMBus, FRU, BBP (Battery Backup Power). Click each tab to
view the information.

o Refresh Every X seconds: Enter the number of seconds for the system to refresh.

o Refresh Now: Click this button to refresh the Sensors page immediately.

e Save Layout: Click this button to save the current layout setting.

e Hide inactive item: Check this box to hide inactive items.

e Show History: Check this box to display the sensor records.

Some sensors (e.g., discrete sensors) are not available on certain motherboards, but they are still

displayed in IPMIView.

5.1.1 Discharging Battery
1. The battery can be automatically or manually discharged. In the PSU dialog box (see Figure 5-3), click

the BBP tab.
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Figure 5-3
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2. Click the top right field BBP2. A dialog box appears.

Battery Discharge Setting @
Discharge

@ Uswr (Wil discharge immediately)

Figure 5-4
3. Select Auto and type desired number of days for the battery to discharge automatically, or select
User to manually discharge the battery. Click Update to start.

5.2 Textview

This feature displays the status of each sensor in text list as shown in Figure 5-5.
Plus and minus button can be clicked to fold/unfold sensors by sensor type.
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6 IPMI Devices

Click the IPMI Device tab of the IPMIView management session in the Viewing Window (shown in Figure
6-1 and 6-2) to display the UID, fan, boot, power information and functionality of the BMC firmware
installed in the system.
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Figure 6-1
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o Blink UID LED: Click the switch button for the UID LED to blink when the unit in question is

identified.

Fan Control (Administrator only)

Select the desired fan speed mode. The setting will be applied immediately. Note that available

speed options vary.

Boot Control (Administrator and Operator only)

Select the boot device in the Next Boot pull-down menu. The setting will be applied immediately.

Power Control

o Power ON (Administrator and Operator only): This feature will power on a managed system.

o Power Down — Immediate (Administrator and Operator only): This feature will power off a

managed system.
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o Graceful Shutdown (Administrator and Operator only): This feature has the same function as
“shutdown” in Windows. Using this feature will cause the managed system to enter the S5 state.
A graceful shutdown will inform the OS running on the managed system to shut down within a
specified time. When the OS running on the managed system receives a graceful shutdown
request, it will start to shut down the system.

o Power Cycle (Administrator and Operator only): This feature will turn off the power to a
managed system for a few seconds and then turn it on again.

o Power Reset (Administrator and Operator only): This feature resets a managed system.

o Warm Reset (Administrator only): A warm reset allows the current settings of interrupt enables,
thresholds, etc. unchanged while communications interfaces are reset. Selecting the Warm
Reset radio button allows you to reset the BMC. Click Yes to warm reset the BMC and the

session will be terminated immediately. You may try a Warm Reset if the system hangs.

o Cold Reset (Administrator only): A cold reset allows the BMC to restore to the default settings
of interrupt enables, event message generation, sensor scanning, threshold values, and other
“power up default” state. Selecting the Cold Reset radio button to reset the BMC. After
confirming the reset of the BMC, the session will be terminated immediately. This feature is
rarely used, for example when you suspect a system malfunction.

Device Information

This panel shows all the FW revisions of the BMC, BIOS, CPLD, Redfish and IPMI. Board model

information and power state information are also provided here.
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7 BMC Settings

(Available for the Administrator only)

Click the BMC Setting tab of the IPMIView management session in the Viewing Window (as shown in
Figure 7-1, 7-2, 7-3 and 7-4) to display detailed information on the Network, SNMP trap, SMC RAKP and

Date-Time configuration in sub-tab respectively.
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e Network Configuration

This feature displays the IP address, the LAN MAC, the Gateway IP, the Gateway MAC, LAN interface, a
router’s IP address, and the Subnet Mask of the BMC and allows you to modify these settings.

To configure the VLAN Tag setting, you can enable the VLAN (Virtual LAN) Tag setting by clicking the
checkbox of Enable VLAN Tagging on the right and entering the value in the VLAN Tag field.

@ Note: Please make sure both MAC addresses of LAN and gateway for the BMC are correct
before clicking the Save button. Be especially careful when you enter the MAC address of
LAN. If the entered address is incorrect, the connection between IPMIView and the

system will no longer be established.

e SNMP

This displays the SNMP trap configuration of the system that needs to receive the SNMP traps generated
by the BMC to allow you to modify the settings. To change the configuration on the BMC, enter the
SNMP community name in the Community text field, and enter the IP address as well as the MAC

address in the SNMP Trap Receivers table in the SNMP group. Then, click the Save button.
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The SNMP Trap may have multiple destinations. When any critical error occurs, an SNMP trap packet
will be sent to all receivers in the list. To remove an SNMP receiver, you may change both IP and MAC

addresses to 0.0.0.0 and 00:00:00:00:00:00 respectively. Then, click Save.

For a system to receive the SNMP traps, you must install and run an SNMP trap receiver program. The
managed system will send out an SNMP trap packet to all receivers when an event occurs. If an SNMP

trap receiver is not running, the trap packet is discarded, and cannot be queued anywhere.

@ Note: SNMP trap can display SNMPvl and SNMPv3 protocol. If the protocol is

unsupported, the trap list will display with "N/A".

e SMC RAKP
Clicking this button allows you to enable SMC RAKP mode. A confirmation dialogue box will appear.

After clicking OK button, the session will be terminated immediately.

@ Note: Under administrator privileges, new settings will apply to the login tab.

Please refer to Figure 3-1 and the Q&A Appendix for more information.

e Date and Time

This feature displays NTP status, time zone, primary NTP server, secondary NTP server, current date-
time and daylight savings time of the BMC. It allows you to modify these settings other than date-time.
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8 Users

IPMIView supports user account and FRU information sub-page in user tab of the IPMIView
management session from 2.20.0 version. Click the right-top combo box to switch sub-page as shown in

Figure 8-1.
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Click the Users tab of the IPMIView management session in the Viewing Window (as shown in Figure 8-2

and Figure 8-3) to display detailed information on the Users management, advanced settings.

We strongly recommend that you change the password immediately for security reasons.

e USERS

o User Name

IPMIView allows you to add or delete a user, to change a user’s password, to set and update

network privilege and SOL privilege settings by clicking the appropriate button.

o Privilege

This feature allows you to set and update privilege level for a user or delete a user from the list.

There are six privilege levels, Callback, User, Operator, Administrator, OEM, and No Access. Only the

three privileges are supported. Privilege Levels determine which IPMI commands a user can execute

over a channel. Privilege Limits set the maximum privilege level that a user is allowed to operate at.

A user is granted certain privileges for each channel, and the user can operate at a privilege level

that is granted. Choose network privilege radio button to change the privilege level setting for a user.

Group Privilege Levels

User Only the basic commands are allowed. These commands are used to read
and retrieve data, to modify BMC configuration settings, or to write data to
the BMC or other controllers. Actions such as resets, power on/off, and
watchdog activation are not allowed.

Operator All BMC commands are allowed, except for commands that can modify out-

of-band interface settings. For example, the Operator is not allowed to
disable individual channels or change a user’s access privileges.

Administrator

All BMC commands are allowed, including modifying commands. An
Administrator is allowed to execute configuration commands that disable
the channel over which the Administrator is communicating.
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8.1.1 Advanced Setting

File Edit Session Manage Help
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Figure 8-4

Click the Users tab of the IPMIView management session in the Viewing Window (as shown in Figure 8-4)

and Advanced Settings title bar to expand detailed settings.

IPMIView allows you to change failed login attempt lockout threshold, failed login counter reset and
account lockout duration settings by clicking the appropriate radio button.

6 Notes:
A e |tis supported by X12 and later platforms.

e Failed Login Counter Reset value cannot be greater than Account Lockout Duration.

Supermicro IPMIView User’s Guide



8.2 FRU Information
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Figure 8-4

Click the Users tab of the IPMIView management session in the Viewing Window (see Figure 8-4)

and right-top combobox to display FRU information.

e FRU (for IPMI 2.0 only)

This provides useful information on the board and the product, including the serial number, part
number, and the motherboard components. Click the Update FRU tab to update the board information
and product information, including information on the manufacturer, the name of firmware, the serial
number/ the part number of the motherboard, and the part/model number of the BMC firmware, the
version and the serial of the IPMI/BMC firmware. In some RoT systems, FRU data is considered as critical
data. When an FRU entry is updated, it will be further backed up to flash. Due to the backup, writing

FRU data to system on RoT platforms may take much longer than on other platforms.
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9 Text Console Redirection (SOL- Serial-
Over-LAN)
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Figure 9-1

Click the Text Console tab on the bottom toolbox (Figure 9-1) to enable Text Console Redirection
support, which will allow you to control a remote system from a text mode console. Click the Start
button to start the text console redirection. Click the Stop button to stop the text console.

e BMCforIPMI 1.5

Console Redirection is not supported by the IPMI specification V1.5. Supermicro provides this useful
feature for a manager to control the managed system from a remote location. When a managed system
is booting up during the POST routine, and no other software application are available for you so that

you can gain control over console redirection, IPMIView provides you with this valuable feature.
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Console Redirection will redirect the monitor of a managed system for IPMIView use and allows you to

send the key codes to the managed system.

When a managed system changes its video mode from Text Mode to Graphics Mode, a termination
notice will be sent to IPMIView to terminate the console redirection. Text Console Redirection only

works with the text mode.

@ Important Note: Console Redirection can cast a very heavy load on a managed system. It

will redirect the whole monitor to the manager’s system, and it will slow down the managed
system significantly. We suggest that you use this function only when you absolutely need it.
For other applications, a proper console redirection software application (pcAnywhere,
Symantec Corporation) or a remote login protocol (telnet) is recommended. When you
finish your remote operation, click Stop to terminate console redirection to take the load off

the managed system.

e BMCforIPMI 2.0

Serial-Over-LAN (SOL) was designed to support Text Console Redirection based on the IPMI specification
V2.0. This function performs better in IPMI 2.0 than in IPMI 1.5. The Text mode console is supported by
the Windows 2003, even when the OS is running. To support Text Console Redirection on the Windows
2003, Special Administration Console (SAC) must be enabled. To enable SAC, follow these steps:

1. Enable Console Redirection in the BIOS, and set it to COM 2 (or COM B)

2. Modify boot.iniin C:\. Boot.ini is a hidden file. An example of boot.ini is listed below.

[boot loader]

redirect=com2

redirectbaudrate=19200

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Standard" /fastdetect

/redirect
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To enable Text Console Redirection support on a Linux Platform:

1. Host A with the IPMI BMC installed (for the Linux Platform):
a) BIOS POST:
(i) Enable "Console Redirection" in BIOS Setup. For example, COM2 / 19.2Kbps / 8N1
(i) Disable "Enable Console Redirection after POST" in the BIOS setup.

b) Boot Loader:

(i) For GRUB, add the following TWO lines into /boot/grub/grub.conf,
but comment out "splashimage=(hd0,0)/grub/splash.xpm.gz"
serial --unit=1 --speed=19200 --word=8 --parity=no --stop=1
terminal --timeout=10 serial console
#splashimage=(hd0,0)/grub/splash.xpm.gz

(ii) Then add "serial console=ttyS1,19200n8" to the end of kernel /vmlinuz in
/boot/grub/grub.conf.

For example:

kernel /vmlinuz-2.6.5-1.358smp ro root=LABEL=/ rhgb quiet serial console=ttyS1,19200n8
This will result in all boot messages being output to the console ttyS1, but you will not see. All
these boot messages on the local console until the login message prompts.
c) LINUX OS:
(i) Add the following line into /etc/inittab.
s0:2345:respawn:/sbin/agetty ttyS1 19200
(ii) Edit /etc/securetty and add ttyS1
2. Host B with IPMIView installed:
a) Install and run IPMIView.
b) Log in Host A with the IPMI BMC installed as Admin.

c) Start Console Redirection in IPMIView immediately after the Host A reboots.

You will see the BIOS POST, the boot loader, and the Linux OS messages and prompts.
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10 KVM Console (KVM-Over-IP for Video
Redirection)

KVM Console Redirection is a new feature included in the Supermicro Intelligent Management (SIM)
Module. If Video Console Redirection support is enabled, the remote screen will be redirected to
IPMIView. BIOS POST, BIOS settings, DOS, Windows or Linux OS screens can all be redirected to
IPMIView. KVM Console will be disconnected if the user performs a FW update or BIOS update.
Administrative privileges are required (Linux: sudo, Windows: Run as administrator) to perform the
virtual storage mounting function.

IPMIView supports Java plug-in and HTMLS version of KVM since 2.20. An example below shows Java
plug-in version of KVM first.

Select Java plug-in radio button to switch to Java KVM interface, and then click the Launch KVM Console
tab to launch KVM console redirection. For product X10 and later, an iKVM console will pop out. Figure
10-1-1 shows sample screenshots of Video Console redirection. The screen of a remote managed system
will be redirected to IPMIView. You will see the screen of the remote system just as if you were sitting in
front of the system.
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IPMIView 2.19.0 (build 210128) - Super Micro Computer, Inc. }
File Edit Sesion Manage Help

@ ‘ Java iKVM Viewer [10.147.160.2 SSL] - Resolution 800 X 600 - FPS 31 I‘EL;
@
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i) Login [ EventLog | Sensors
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Figure 10-1-1

° Virtual Media: To mount a virtual storage or to open virtual keyboard.

Virtual Storage

Virtual Keyboard

° Record: This function is to start/stop the record screen.

. Marco: Marco and hotkey settings.

Options Use
[J Hold Right Alt Key
[0 Hold Left Alt Key
Right Windows Key }
Left Windows Key
Macro ]
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Power control: To perform power control of this system.

| Set Power On
Set Power Off

Software Shutdown
Set Power Reset

Due to platform characteristics, there are a little difference in Ul for earlier Supermicro product like X9.

For these kinds of platforms, a “Video Console” tab will show up instead of “KVM Console.”
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Figure 10-1-2
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Toolbar

There are several tool buttons that can be used for video console as shown in Figure 10-2.

ZoomIn
Select Percentage for Scaling Screen
Zoom Out
Send Ctrl+Alt+Del to Remote

Auto Adjust Screen
=] 192.168.10.249

> ® O

Cirl+2&k+Del | Qptions

@ [100% ~ |

Open or Close Quick Shot Panel Options

Quick Shot
Screen Capture

Full Screen

Stop Video Redirection

Start Video Redirection

Figure 10-2 Video Console Toolbar

|} Start Video Redirection:
This button is used to start video redirection. IPMIView will automatically start the video redirection
when you click the Video console tab.
O Stop Video Redirection:
This button is used to stop video redirection. To stop video redirection, press this button again to stop it.
Please note that the drive redirection will continue to work when it is enabled.
Full Screen:
[ —wa ]
This button is used to maximize the size of the remote video screen on the local computer display. You

may press <Alt + Enter> to return to the original mode. Please refer to Figure 10-3.
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Screen Capture:

This button is used to capture the screenshots of the remote managed systems. You will see a file-save

dialog box with a preview image. Select the directory and filename to save it. The file format can be PNG

@ Quick Shot:
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Figure 10-3

G L

[Hide panel!

This button is used to capture quick screenshots. You will need to first specify a directory where you

want to store quick shot images. You will see the quick shot images in the quick shot panel. Please refer

to Figure 10-4.
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Open or Close a Quick Shot Panel:

This button is a switch used for opening or closing the quick shot panel. Double-click the image in this

panel to show a full-size window for viewing.

@§ Zoom In:

This button is used for zooming in the screen (up to 300%). Please refer to Figure 10-5.
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Figure 10-5
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@Q Zoom Out:

This button is used for zooming out. The maximum zoom out percentage is 10%. Please refer to Figure
10-6.
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Figure 10-6

m Select percentage for Scaling Screen:
This combo box allows you to select the setting of screen scaling, either 10%, 25%, 50%, 75%, 100%,
200%, 250% or 300%. An additional selection allows you to scale to fit with the IPMIView window size.
ctri+at+0el - Send Ctrl + Alt + Del to Remote:
This button is used to send the <Ctrl + Alt + Del > key combination to the remote system. It is useful
when the remote system is running in the BIOS, DOS or Windows environment.

I@' Auto Adjust Screen:

This button is used to adjust the screen automatically. Click this button if it’s difficult for you to see the

whole screen.
options  Options:

You can select more options here. The list of options is listed below.

* Monitor Only: Use this feature to display the remote screen only. The keyboard and mouse will be
disabled.

* Readability Filter: This item uses algorithm to improve screen display. This will allow you to see the
text content easier when you scale the screen.

¢ Local Cursor: Use this to change local cursor settings.

e Chat Window: This feature allows the user to chat with each other via the IPMI connection. Please

refer to Figure 10-7.
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17192 168.10.24 Chat @

Jim@IEM-I0CA4107030 super }== test
root@linuxisuper )= 456

Jim@IBM-DDCE4107D3D(super) | [~ Beep

Figure 10-7 Chat Window

Video Settings: This feature allows you to configure the advanced video settings. Please refer to

Figure 10-8.

17 Video Settings X

Brightness 4 | M| | 70
ContrastRed _+ | 0 | 114
Confrast Green _« | Il ] 110
ContrastBlue  « I | 112
Clock | I = 1344
Fhase Xl I 29
Horizontal Offset < | 0 | 308
Vertical Offset  «| | ] 34
[Reset this Mode || Reset All Modes |
Save Changes | 1,024x768 60Hz Undo Changes

Figure 10-8 Video Settings
Refresh Video: This feature allows you to refresh the video screen.
Soft Keyboard: A virtual keyboard is provided for easy input. It also provides localized keyboard

mapping. Please refer to Figure 10-9.

English (United States) 104pc =3
Es;  F1|F2|F3|F4|FS|FBIFTFSFAF10F11F1z P & | Brk
10234867830 - =<In~ L& -
"—iqwert\,fuiop[]JDeIEnd?l;'K‘!‘I+
lals|d{flaglhlilk{1I]:]"|} +— 5|+
iV |z|x|c|v|b|nim|,| . |f| ©F 1| Edd |3
d
cirl | st|Al ait | ste ctn <[4+ ins [De

Figure 10-9 Soft Keyboard

Local Keyboard: This feature allows you to set local keyboard mapping settings.

Encoding: This feature supports encoding for the video screen. The options for encoding are

“Predefined,” “Compression” and “Color Depth.”
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Status Bar
Figure 10-10 displays the status bar for the video redirection.

Message Frames per second and In/Out bytes per second
Start Video redirection Fps: 20 In: 184 KB/= Out: 204 Bi= i j Q)@

Share Mode J Monitor Mode

Figure 10-10

Start Video redirection
Message:

This section displays tool tip information and the video redirection status.

Fp=: 20 In: 184 KB/z Out: 204 Bi=z

This section indicates the number of the frames displayed per second, and Input (Kbytes per second)/
Output (bytes per second).
3
z‘ Share Mode:

This icon indicates the status of screen-sharing on the remote system. If there is only one user using the

)
video redirection of a remote system, the icon will look Iike‘ If two or more users using the video

3
redirection of the same remote system, the icon will look like i‘ .
& Monitor Mode:
- )

This icon displays the status of monitor mode. When the display looks like (&g , it indicates that you

can use the local keyboard and the mouse to control the remote screen. When the display looks like

% , it indicates that the local keyboard and the mouse are not available. If you select the option

“monitor only”, the keyboard and mouse will be disabled.
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Login EwventLog Sensors IPMI Device BMC Setting Usrs TextConsole EVM Console

Switch KV Interface to HTMLS succeszfully

Click HTML5 radio button to switch to HTML5 KVM interface, and then Click the Launch KVM Console
tab to launch HTLM5 KVM console redirection. Figure 10-11 shows sample screenshot of a warning
message appears when a new connection to the BMC is established for the first time. Click the Continue
to “BMC IP address” (unsafe) link to proceed. For product X10 and later, an HTML5 KVM console will
pop out by default browser. Figure 10-12 shows sample screenshots of HTML5 KVM Console redirection.

A

Your connection isn't private

Attacioars might be trying to stesl your information from 0947 1868.7 (for example. passwords

messages or credit cards)

e s m

This server couldn't prove that it's 10.147.160.7; its security ceificate is not tusted by

your computer's operating system. This may be caused by a misconfiguration or an

attacker intercepting wour connection

wntinue do 1.147.160.7 junsafs

Figure 10-11

Supermicro IPMIView User’s Guide



Figure 10-12

Note: HTML5 KVM requires a SFT-DCMS-Single license on X10 and X11 generations of
motherboards.
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11 Virtual Media

IPMIView provides virtual media functions for different generations of motherboards. The older one is
Supermicro Intelligent Management (SIM) Module and the later one is SIM (WA) Modules, which is
applied on the ASPEED AST2400 and later BMC. IPMIView will automatically show up on the virtual
media tab if the device is supported. However please note that this function requires a license. You need
to enable either SFT-OOB-LIC or SFT-DCMS-Single on the target device.

11.1SIM Module

The Supermicro Intelligent Management (SIM) Module provides a Virtual Media feature, which includes
a Virtual USB Floppy, a CD-ROM image and Drive Redirection.

Figure 11-1 shows the Virtual Media GUI. The Virtual Media Status section displays the current virtual
device status. There are two virtual drives available.

Floppy Image Upload allows the user to upload a floppy image as "floppy" located at the remote host.
The floppy image uploaded shall be in the binary format with a maximum size of 1.44MB. It will be
loaded to the Supermicro SIM card and emulated to the host as a USB device.

The CD-ROM Image on the “Windows Share” allows the user to configure Windows-Share settings. It
allows you to decide how you want to share the data stored in your shared folder with the users on the
remote host system.

Drive Redirection makes local drives accessible to other users via console redirection. This function
allows you to share your local drives (floppy, CD-ROM and HDDs) with users on remote systems.
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192.168.10.241

Virtual Media Status
Drrive 1

Type : Floppy image

Read / Write mode: Writahle
File name : floppy.img (1474560 botes)

Floppy [mage Tpload

Drrive 2
Empty

CD-ROM Image on Windows Share

Dirive: |2 v | [ =1 Open ] [ Tpload TDirive:
Floppy Tmage file: Share host:
| CMloppy.img Share name:
Path o image:
Tpload floppy image dons Tser {optional)
Paszwornd (optional):
Dirive Redirection
Not comnected
Divive Redirection disconnescted
Drive 2:|  Connect Drive ][ Comnect 30 [Not comnected

Divive Redirection disconnescted

(@b ] ®

Login | Event Log || Sensors | IPMIDevice | BMC Setting | Teers| Text Console | EVM Cnnso]e| VmMediﬂ|

Figure 11-1
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Floppy Image Upload

As shown in Figure 11-2, click Open File to select the file that you wish to upload to a specific host drive
of your choice. Click Upload to upload the floppy image. Please wait for the uploading process to
complete. The virtual floppy will be activated after the floppy image is uploaded.

Flopgy Image Uplosd

Drrive:

Floppry Inage file:

Coifloppy img

Uplosdling floppy imsage

Figure 11-2
CD-ROM Image on Windows Share
Please refer to Figure 11-3 for the following items.
* Drive: Specify the drive that you want the remote host to share.
* Share Host: Enter the IP Address or the name of the system you wish to share data with via

“Windows Share.”
* Share Name: Enter the name of the shared data in the remote host.
* Path to Image: Enter the location of the source file that you wish to share via “Windows Share.”
e User/Password (Optional): Enter the user name and password for the person to access the data

that you want to share, and click the Set button to enter your selections as shown in Figure 11-3.

CO-ROM Image on Windows Share

Drive: |2

Share host: 192 16310117
Share name: =t
Path to image: CO SO

Uzer (optional):

Passward (optional);

Figure 11-3
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Drive Redirection

As shown in Figure 11-4, Drive Redirection supports both local drive and the ISO file. When you click the

Connect Drive button, a dialog box (Figure 11-5) will show up.

* Local Drive List: This box displays a list of local drives available for remote access. Select from the list
a local drive that you want to make accessible for a remote server.

¢ Refresh List: Click this button to refresh the local drive list.

¢  Write Support: Check this button to allow the remote operating system to have write access to the
drive that you have selected. This function allows a user to alter, overwrite, erase and destroy data
stored in the drive selected. This feature should only be used with non-critical data. Select the drive

and click OK to start direct redirection.

The second type of drive redirection is “Connect ISO”. You may redirect the 1SO file directly from your
file system. Click this button and select an ISO file to start this function.

Dirive Redirection

Drivel:[ Connect Drive ” Comnect [30 ]Notconnected

Cancelled Drive redivection

Diive 2:[ Connect Drive ][ Comnect [30 ]Notconnected

Dirive Redirection disconnected

Figure 11-4

!

:j Select a drive to redirect

C: {Haxd Disk) v [ Refresh List ]

[ ] Enable Write support

(oK ) (Conet |

Figure 11-5
Stop Active Drives

As shown in Figure 11-6, click Stop Drive 1 to disable Drive 1 and Click Stop Drive 2 to disable Drive 2.
The Refresh button is used for refreshing the Virtual Media settings. If you want to stop or change the
type of a virtual drive, you first need to stop it.

[ @stopDrive! | [ @ StopDrive | [ Refresh

Figure 11-6
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11.2 SIM (WA) Module

The SIM (WA) Module provide a CD-ROM image feature that allows users to share data via “Windows
Share” (Windows) or "Samba" (Linux).

& 10.147.1602 BN 1014716014
Virtual Media Status

Device 1: There is an ds0 file mounted
Device 2: Empty device
Device 3: Empty device
Firtual CD-ROM
Share host:
Path to image:
Tser {optional):

Password (optional);

Mount Mot Retresh

Login EventLog Sensors IPMI Device BMC Seting Users TextConsole KVM Conmle  Virmal Media

Figure 11-7
e  Virtual Media Status: Displays the current virtual device status.
e Virtual CD-ROM: Allows users to configure Windows-Share or Samba settings. You can decide how
to mount the data stored in your shared folder to the target device.
o Share Host: Enter the IP address or the name of the system where the source data is located.
o Path to Image: Enter the location of the source file on the share-host.
o User/Password (Optional): Enter the username and password for the share-host if needed.
o Mount: Click the Mount button to connect the source, which will automatically refresh after
mounting.
o Unmount: Click the Unmount button to disconnect the source, which will automatically refresh
after unmounting

o Refresh: Click the Refresh button to update the virtual media status.
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12 Group Management

Group management is a way to manage multiple servers at the same time. For example, you can query
the fan sensor readings from multiple servers and note their differences. Also, you can simultaneously
power on or off multiple servers at the same time. As shown in Figure 12-1, click the Manage Group
button to show the Group Management screen. In Group Management, you can select multiple
servers from the host group on the left and manage them with the functions provided. You may re-
arrange groups of servers in the group list to make server group management easier.

T7 IPMI View ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

File Edif Session Help
bEagoe R
S . 1 Group Management

UPERMICR. Fanl Voltage | Sensors| EventLog| ACPI| Power| LAN Config | FRU | Text Console | General Info
I IPMIDomain =~ & v © Tt @ | 22

192.168.10.240 =00

34 Fan
=] 152168 10242 System Nome P Sensor Name Reading Tnit Low Limit
iry| 192.168.10.243
25| Groups BR& &P
[ TPM1 Dornain (444)
[[] Refresh every seconds
GGet Virtual Medin information done
Figure 12-1

In the group management, a Login ID and password are required. Click Manage> Setting to set the login
information. Please note that IPMIView will use this account to login to multiple servers (Figure 12-2).

Gromp Login Sething r5_<|

1) LoginID ADMIN]
R

save [0 and Password
* A dmindstrator level is requived

Figure 12-2

IPMIView allows servers to be grouped in the following categories:
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Fans
Temperature
Voltages

Sensors

Event Log

ACPI

Power

LAN Configuration
FRU

Text Console

General Information

Group Management
Fah | Temperature | Yoltage | Sensors | Event Log | 2CP1 || Power || LAM Config | FRU || Text Consale | General Info

Figure 12-3
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Fans

After you've selected multiple servers and clicked the Fan tab, a window will display as shown in Figure
12-4. You can press <Ctrl+Click>, <Shift+Click> or dragging your mouse to select servers. Click the Query
button for IPMIView to collect the fan readings from the selected servers. The information listed in the
table shows the fan status of the selected servers. If a fan reading is colored in red, the fan may be
broken, not installed, or the reading is below the lower limit. When this occurs, the Administrator should
take precautionary measures to ensure that the system functions properly.

You may refresh the fan status by checking the Re-flash checkbox. IPMIView will refresh the fan status
based on a preset schedule. Please note that IPMIView will not refresh if you switch to another tab.

[ IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc. EEK

File Edit Session Manage Help

BE & Bde 2

SUPERMICR® 75 87et% Mansgerert

A v FEa
r-g Sstemn Name 1P Sensor Name Reading it Low Limit
E\ ggiggigéﬁ 192.168.10.241 192.168.10 241 [Fanl 0 RPM 600
R 192.168.10.241 192.168.10 241 [Fan2 4700 RPM 600

192.168.10.241 192.168.10 241 [Fan % 0 RPM 600
192.168.10.241 192.168.10 241 [Fand 0 RPM 600
192.168.10.241 192.168.10 241 [Fan5 0 RPM 600
192.168.10.241 192.168.10 241 [Fanf 0 RPM 600
192.168.10.241 192.168.10 241 Fan7ACFU1 0 RPM 600
192.168.10.241 192.168.10 241 FanBACFU2 1800 RPM 600
192.168.10.131 192.168.10.131 [Fanl 0 RPM 600
192.168.10.131 192.168.10.131 [Fan 0 RPM 600
192.168.10.131 192.168.10.131 [Fan % 4a00 RPM 600
192.168.10.131 192.168.10.131 [Fand 0 RPM 600
192.168.10.131 192.168.10.131 [Fan5 0 RPM 600
192.168.10.131 192.168.10.131 [Fanf 0 RPM 600
192.168.10.131 192.168.10.131 Fan7ACFU1 0 RPM 600
192.168.10.131 192.168.10.131 [FanBACFU2 0 RPM 600

25| Groups EEEE

MR TP Dioosdn (545
[] Refiesh every s last updated :2007/10/01 15:59:06 (16)

Finish

Figure 12-4
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Temperatures

The screen shown in Figure 12-5 indicates that multiple servers have been selected, and the
Temperature tab is pressed. Clicking the Query button allows IPMIView to collect the temperature
readings from the selected servers. The information listed in the table shows the temperature settings
of the selected servers.

Lj IFMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

File Edit Session Manage Help
BE & Bde 2
SUPERMICR® 7 8otk Mansgerert
Fan | Temperatore | Voltage | Sensors | Event Log | ACPT | Power | LAN Config | FRU | Text Console || Genexal Info
086 2 q [
Temperature
Sstemn Name 1P Sensor Name Reading it High Limit
E\ ggiggiggﬁ 192.168.10.241 192.168.10 241 ICPU Temp 1 250 degres C 750
R 192.168.10.241 192.168.10 241 CPU Temp 2 220 degres C 750
192.168.10.241 192.168.10 241 CPU Temp 3 0.0 degres C 750
192.168.10.241 192.168.10 241 CPU Temp 4 0.0 degres C 750
192.168.10.241 192.168.10 241 vz Temp 220 degres C 750
192.168.10.131 192.168.10.131 CPU Temp 1 5a.0 degres C 750
192.168.10.131 192.168.10.131 CPU Temp 2 0.0 degres C 750
192.168.10.131 192.168.10.131 vz Temp 400 degres C 750
25| Groups EEEE
MR TP Dioosdn (545
[] Refiesh every s last updated :2007/10/01 15:59:25 (8)
Finish

Figure 12-5

Supermicro IPMIView User’s Guide



Voltages

After selecting multiple servers and Voltages settings, you will see the display as shown in Figure 12-6.
Clicking the Query tab will allow IPMIView to collect the voltage readings from the selected servers. The
information listed in the table shows the voltage status of the selected servers.

(7] [PMI View ¥2.6.29 (build 070927) - Super Micro Compater, Inc. =13

File Edit Session Manage Help

BE @ Gd e 2

SUPERMICR@ & Crovp Mansgement
Fan Temperatu.re| Voltage |Sensors Event Log | ACPI| Power| LAN Contfig | FRU | Text Console | General Info

il IPMI Domain =~ & + § £ &
Sstemn Name 1P Sensor Name Reading Tnit Low Limit High Limit

_ 192168.10241 [192168.10241 [CPUL Veors 122 Valts 108 161

7] 192.163.10 243 107.168.10241  [192.168.10341 (P02 Veore 0 Tolts 108 161
192166.10241 |192.168.10241 (337 528 Valts 206 363
192168.10241 [192.168.10241 |57 ! Volts 148 543
192166.10241 |192.168.10241 127 1160 Valts 1075 1324
192168.10241 |192.168.10241 127 126 Volts 132 108
192166.10241 |192.168.10241 (.57 147 Valts 134 164
192168.10241 |192.168.10241 [5YSE 475 Volts 148 543
192166.10241 |192.168.10241 [VBAT 324 Valts 206 363
192168.10131 |192.168.10131 |CFUL Veors 136 Volts 108 161
192166.10131 |192.168.10131 |CPUZ Voors ] Valts 1.0 161
192168.10131 |192.168.10.131 .37 ] Volts 296 383
192166.10131 [192.168.10131 |57 441 Valts 148 540
192168.10131 |192.168.10.131 127 1132 Volts 1075 1324
192166.10131 |192.168.10131 [575E 436 Valts 148 540
192168.10131 |192.168.10.131 [TBAT 515 Volts 296 383

=5l Groups E&de

IPMI Domsin (5/5)
[] Refissh every _— st updated 200710001 15:59:27 (16)
Finish
Figure 12-6
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Sensors

After selecting multiple servers and clicking the Sensors tab, you will see the window as shown in Figure
12-7. Click the Query button for IPMIView to collect the sensor readings from the selected servers. The
information listed in the table shows the sensor status of the selected servers. The window here shows

the chassis status and power supply status. If the chassis is opened or a power supply has failed, the
reading will be in red.

7 IPMI View ¥2.6.29 (build 070927) - Super Micro Computer, Inc. CEXx
File Edit Sesion Manage Help
BE & 00e 2
S C . J Group Management
UPERMI R‘ Fan | Temperatice Vohage| SEDSDTS|EventL0g ACPT | Power | LAN Config | FRTT | Text Console | General Info
I IPMIDomain & - @ £ & | 5= e
Power Suppy and Introsion
[Tfl s Sstern Name IF Sensor Name Statuz
= ig;igg}g%ﬁ 192.168.10.241 192.168.10.241 Intrusion (Chassis OK
51 e 192.168.10.241 192.168.10.241 Power Supply Power Supply O
192.168.10.131 192.168.10.131 [ntrusion i-hassiz Opened |
192.168.10.131 192.168.10.131 Power Supply Power Supply O
=5 Groups Bdae
MM TP Diomadn (5/5)
(e soramnds Tast npdated Z007/10/01 15:59:32 (4)
Finish
Figure 12-7
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Event log

After selecting multiple servers and clicking the Event Log tab, you will see a display as shown in Figure
12-8. Click the Query button for IPMIView to collect the event logs from the selected servers. The table
below displays the event log of the selected servers. Select the Host combo box to filter the event log
data in the table.

;j IFMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

CEX

File Edit Session Manage Help

Ea 30

2 ®

SUPERMICR®

A v Q f @

IPMI Domain
192.165.10.13

j Group Management

Fan | Temperatore | Yoltage Sensors| EventLog | ACPI| Power| LAN Config | FRU | Text Console | General Info

m =

192.162.10.240 SEL
Sarstermn Name: |A]l w
] 192.168.10.243 System Name i3 Time Stamp Sensor | Event Type

192.168.10.241 192.168.10.241

053/1042007 14:22:09 Fri

Die-azsertion: Phorsical Security (Chassis Int ~

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

b ssertion: Lower Mon-crifical - going low =

192.168.10.241 192.168.10.241

053/1042007 14:24:02 Fri

Azsertion: Lower Critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

b ssertion: Lower Non-recoverable - going

192.168.10.241 192.168.10.241

053/1042007 14:24:02 Fri

.. |Azmertion: Lower Non-critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.. [ssertion: Lower Critical - going low

192.168.10.241 192.168.10.241

053/1042007 14:24:02 Fri

.. |Azmertion: Lower Non-recoverable - going

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.| Assertion: Lower Non-critical - going low

192.168.10.241 192.168.10.241

053/1042007 14:24:02 Fri

.| Aszertion: Lower Critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.| Assertion: Lower Non-recoverable - going

192.168.10.241 192.168.10.241

053/1042007 14:24:02 Fri

. |Azertion: Lower Non-critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

. [Lssertion: Lower Critical - going low

192.168.10.241 192.168.10.241

053/10/2007 14:24:02 Fri

. |Azmertion: Lower Non-recoverable - going

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.. [Lssertion: Lower NMon-critical - going low

192.168.10.241 192.168.10.241

053/10/2007 14:24:02 Fri

.. |hmertion: Lower Critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.. [Lssertion: Lower Non-recoverable - going

Groups
TPMI Domadn (5/5)

B&&e

192.168.10.241 192.168.10.241

053/10/2007 14:24:02 Fri

.. |hzertion: Lower Non-critical - going low

192.168.10.241 192.168.10.241

03/10/2007 14:24:02 Fri

.. [Lssertion: Lower Critical - going low

192.168.10.241 192.168.10.241

053/10/2007 14:24:02 Fri

.. |hzmertion: Lower Non-recoverable - going

192.168.10.241 192.168.10.241

03/10/2007 14:34:34 Fri

b ssertion: Lower Mon-critical - going low

192.168.10.241 192.168.10.241

053/10/2007 14:34:34 Fri

Assertion: Lower Critical - godng low

192.168.10.241
<

192.168.10.241

03/10/2007 14:34:34 Fri

Azertion: Lower Non-recoverable - going %
| 4

[] Refresh every sconds

last updated :2007/10/01 16:01:43 (395)

Finish

Figure 12-8
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ACPI

After selecting multiple servers and clicking the ACPI tab, you will see a display as shown in Figure 12-9.

Click the Query button for IPMIView to collect the ACPI state from the selected servers. The table
displays the ACPI state of the selected servers.

(7] [PMI View ¥2.6.29 (build 070927) - Super Micro Compater, Inc. =13

File Edit Session Manage Help

BE e Ode 2
SUPERMICR@ [ Crove Mansgement
Fan| Temperatoee | Voltage | Sensors EventLog|ﬁCPI |Power LN Config | FRU | Text Console || Genexal Info
i IPMI Domain =~ 4 - § £ & | 3
- S 0 [
ACH
Sstemn Name IF ACPT Btate Description
[ 192.168.10.243 19216810241 [192168.10241  [30/GO working
19216810131 [192168.10131  [30/G0 warking
=5 Groups B&de
il IPMI Domain (5/5)
@B seoomds Tast updated 2007001 16:02:05 (2)
Finish
Figure 12-9
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Power

After selecting multiple servers and clicking the Power tab, you will see a display as shown in Figure 12-

10. Click one of the Power Control buttons to send a command to the selected server. The text area will
show the result.

;j IPMI ¥iew ¥26.20 (build 070927) - Super Micro Computer, Inc.

S[=1ES

File Edit Session Manage Help

BEa gdee
e 1 Group Management
SUPERMICR®

Fan || Temperatore | Voltage | Sensors | Event Log ACPI| P0W3T|LAN Config | FRU | Text Console || General Info
i3 IPMI Domyain A - @ £ @ | Graceful Power Control

[ 192.168.10.131

Soft shutfownivia ACP) | [ Gracefnl Shutlown | [ GracefulReboot | [ Graceful Power Cycls
[ 10241 .
= iz | Gl e Cannl
Bl 15 0.243 [ Power Down ] [ Power Up ] [ Power Cycle ] [ Resmt

Resnlt

[2007A0/01 16:02:42] Sending Power Up to 19216810241, Ok
[2007A0/01 16:02:42] Sending Power Up to 192.168.10.243... OK

Groups & e

MR IPMI Domadn (5/5)

Finish

Figure 12-10
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LAN Configuration

After selecting a single server and clicking the LAN Config tab, you will see a display as shown in Figure
12-11. Click Query to get the information needed from a single server and copy it to other servers for
data-sharing. The text area will show the results of the query and provide updates. The Clear button is
used to clear the text field only; it will not clear the actual LAN configuration from the server.

[ IPMI ¥iew ¥2.6.29 (build 070927) - Super Micro Computer, Inc. (=13

File Edit Sesdon Manage Help

o agEe R e

j Group Management

SUPERMICR. Fan | Temperatore | Voltage | Sensors| Event Log | ACPI | Power| LAN Config | FRIT | Text Console | General Info
i IPMIDomain 4 9 £ @ | LAN Configumstion
Crateway IP: 192.168.10.254 Get |
Gratewray MAC: 00:00:00:00:00:00 Tpdate ]
Subnet Mask: 255.255.255.0 Clear
] 192 165.10.243 Y
Community | public
1IP | 1921681043 1 MAC | 00:00:00:00:00:00 [ et |
2IF | 0000 2MAC | 00:00:00:00:00:00 [ Update |
3Ip 000D 3MAC | 00:00:00:00:00-00 [ Clar |
Result

[2007 10401 16:03:11] Getting LAN Configration from 192.165.10.241... Ok
Gateway [P = 192.168.10.254

Gateway MAC = 00:00:00:00:00:00

Subnet Mask = 255.255.255.0

[2007A0/01 16:03:12] Getting SMMP Configration from 192.168.10.241... Ok
SHMP Destination 1= 152.168.10.43 ( 00:00:00:00:00:00 )

25l Groups & i @ | SWMP Destination 2= 0.0.0.0 (00:00:00:00:00:00 )
MM TF2T Diosin (545 SMMP Destination 3=0.0.0.0 { 00:00:00:00:00:00 )
Finish

Figure 12-11
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FRU

After selecting a single server and clicking the FRU tab, you will see a display as shown in Figure 12-12.
Click the Query button for IPMIView to get the FRU information from a single server, and copy it to
other servers for data-sharing. The text area will show the results of a query and provide updates. The
Clear button is used to clear the text field only; it will not clear the actual FRU data from the server.

(7 IPMI View ¥2.6.20 (build 070927) - Super Micro Computer, Inc. =3
File Edit Sesdon Manage Help

PEaAgEe R e

j Group Management

SUPERMICR‘. Fan | Temperatore | Yoltage | Sensors | EventLog | ACPI | Power | LAN Config|ﬁ| Text Conmle | General Info

M IPMI Domain =~ & - 9 £t @ | FRU
[oet |[ Update | Clear |

Board Info Product Info
k3 Mi Manvfactorer Super Micra
] 192.168.10.243 ECATE g < urer Moo ik
Name IPMIZ0 Name I
Berial Number Parttdodel Number | AOC-IPMIZ0-E
Part Number ACQC-TPMIZ0-E Version 10
Serial Humber
Result

[2007/10/01 16:03:41] Getting FRU fram 192.165.10.241... OK

25| Groups B&d e
Wl TFRI Domain (550

Figure 12-12
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Text Console

After selecting a single server and clicking the Text Console tab, you will see a display as shown in Figure
12-13. Click the Open button for IPMIView to create an internal text console window for the selected
server. Click Start to start the text console redirection. The power control buttons displayed on the
status bar provides power on, power off and reset commands, allowing you to easily power on or power
off a remote server. The Encode checkbox is for RMCP+ encoding. Check it to enable packet encoding
between the IPMIView and a server.

:j IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.

File Edit Sesdon Manage Help
ol aghe R
SUPERMICR® . ouk Mensaemen
Fan | Temperature | Voltage | Sensors| Event Log | ACPI | Power | LAN Config | FRIT | Text Console | General Info
IPMIDomain =~ & ¥ Q £ & TR
[ 102 168.10.131 SeEe
= 192.168.10.240 Priv| Administrator v | [ UTF-E [#] RMCP+ Encryption Erild 070801
=] 1921631024 FhoenixBI0S Setup Utility
] 19216310243 Main Advanced Security Eoot
Item Specific Help
[[Hg: 05:02]
Systen Date: [10/01/2007]
£Tah», <Shift-Tab>, or
BIOS Date 0l/26/07 <Enter> selects field.
Legacy Diskette A: [1.44/1.25 MBE
IDE Channel 0 Master [Mone]
IDE Chamnel 0 Slawve [Mone]
S4T4 Port O [37020ME SATAD]
SATA Port 1 [Mone]
54TA Port Z [Mone]
SATA Port 3 [Mone]
Parallel ATA: [Enabled]
Serial ATa: [Enabled]
Natiwe Mode Operation: [Serial ATA]
EE Groups De & @ % 54T4 Controller Mode Option: [Compatible]
il TP Domsin (5/5)
Help Select Item Change Values Setup Defaults
Exit Select Menu Select > Sub-Menu Save and Exit
Powwer Comtrol :
Finish

Figure 12-13
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General Information

After selecting multiple servers and clicking the General Info tab, you will see a display as shown in
Figure 12-14. Select the fields you want to query from the servers, and click the Query button to allow
IPMIView to collect the information from the selected servers.

:j IPMI Yiew ¥2.6.29 (build 070927) - Super Micro Computer, Inc.
File Edit Sesdon Manage Help

hEmagoe R e

e 1 Group Management
SUPERMICR. Fan | Temperatore | Voltage | Sensors| Event Log | ACPI | Power | LAN Config | FRUT | Text Console | General Info

2R E 0

Select Hems Creneral Information

10241 .
=] 197.165.10 242 RMCE Version

G 192 10.243 Firmware Reversion

| >

Sarstem Name 1P RMCP Versi.. Fimnnware Eeversion TPMI Revision
192.168.10.131 192.168.10.131 |2.0 RMCP+ 0129 20
192.168.10.241 192.168.10.241 |2.0 RMCP+ 0125 20
IPMI Revision 192.168.10.243 192.168.10.243 |20 RMCP+ 01.44 20

SEL Entries

SEL Version

SEL Free Space
Recent Entry Added
Recent Entry Erased
MAC Address
Crateway IP
Gateway MAC
Subnet Mask

SHMP Cummunity

25l Groups Ed& e )
IPMI Domain (55) SNMP Trap Receiver (

SNMP Trap Receiver (v
£ |

Selection

@Al O Basic P

Figure 12-14
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13 Trap Receiver

The Trap Receiver is a utility used for receiving traps from the BMC. In the event of a sensor error or a
sensor reading that exceeds a threshold, the BMC will send SNMPv1/v3 traps to the destinations set in
the BMC. The Trap Receiver is executed on the destination site and receives the SNMPv1/v3 trap from
multiple senders (BMCs). If you select a category, you can see all the traps in that category.
Furthermore, when you click a trap in the trap list, you can see its details in the Trap Structure window.
Please refer to the BMC Setting page in IPMIView to set the SNMPv1/v3 destination.

As shown in Figure 13-1, there are several components to the IPMI Trap Receiver.

* Menu Bar: contains pull-down menus for setting preferences, exiting the programs, getting help,

etc.

* Tool Bar: contains all IPMI Trap Receiver features.

* Category: categorizes the traps by the sender, community and sensor.

* Trap Structure: It is a tree structure that displays traps in detail.

* Status Bar: shows messages regarding the current status of related components.

* Trap List: shows detailed information for traps received.

¢} IPMI Trap Receiver V3.0 (build 210830) - Super Micro Computer, Inc - m] ¥
Menu Bar ——file Help
Toolbar ——- |} O B = m g SNMPv1 SHMPw3
Start Stop Save Load Clear Email
Category al Num Bender Community  Sensor Diescriphion Local Time3 tamp
1 10.147.160.14 [public #0xFF Event Dir : AssertionValve...[202108/30 05:.08:25 Mon
. 10.147.160.14 2 10.147.160.14 [public #0:FF Event Dir : AssertionValve...[202108/20 05:08:39 Mon
2 10.147.160.14 [public #0:FF Event Dir : AssertionValve...[202108/20 05.08:49 Mon
Category —
Sender Comrmunity  Sensor
Trap Structure

Trap Structure

SHMFP Trep ~
| | SNMP Header

i # Mesmge Length: 164

o i Message Version: v1

“. @ Commumity: public

=4 | PDU Header

- # Enterprie: 1.35.1.4.1 310
AgentIP: 10.147.160 14
# Generic Trap Type: 6
- 4 Specific Trap Type: 1308
L Timeticks: 1630300105
- | PDU Body
- # Totsl Length of Variable ]
- | Bind

# Leneth of Binding: 6! ¥
< >

Status Bar

—Trap List

ta trap received: sender IF =10.147 160 7, content = [ 234 ] Systerm smeart power capping 700 W - Asertion

Finish

Figure 13-1
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Menu Bar

As shown in Figure 13-2 and 13-3, click File> Preferences to set the SNMPv3 Trap User Table. This user

table configuration is used to decrypt SNMPv3 traps by Trap Receiver. In the User Table, a Username,

Authentication model, Authentication password, Privacy protocol and Privacy password are required. If

you want to add or remove the configuration of SNMPv3 trap, you first need to click “+” or “-” buttons.

If you want to load other properties file or change file path, you need click the folder path. Click OK to

save the current SNMPv3 Trap configuration settings.

7} IPMI Trap Receiver V3.0
File Help

465 Preferences b

Exit ap

Figure 13-2

8% SNMPw3 Trap User Table

s e

Authetication Model

1 Derekl23 MD3 Testl234 DER Testo078
2 Test SHA-1 Testl 111 AER128 Textd222
3 MD5 DES

c:WworkspacelsnmpUser Table. properties

Cancel
Figure 13-3
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Tool Bar functions

The tool bar provides the following features as shown in Figure 13-4.

2 @ = & i} = SHMPvl  SNMPv3

Shart Stop Save Load Clear Email

Figure 13-4

e Start: starts the Trap Receiver.

* Stop: stops the Trap Receiver.

* Save: saves the SNMPv1 or v3 traps received into a file by selected file extension (see Figure 13-5).

* Load: loads a saved SNMPv1 or v3 trap file into the Trap Receiver by selected file extension (see
Figure 13-6).

* Clear: clears all the SNMPv1/v3 traps in the trap list.

* Email: displays an “Email-Alert Settings” dialog box (see Figure 13-7). Fill the “SMTP server”, “From
(email address)” and “To (email address)” fields. The “From” and “To” addresses must be valid in the
SMTP server. If the SMTP server requires authentication, please enter the username and password.
Once entering needed information, click the Test button to verify if your email works properly.

*  SNMPv1: Displays SNMPv1 traps in Trap List.

*  SNMPv3: Displays SNMPv3 traps in Trap List.

0 Note: For some mail servers, the Enable TLS checkbox should be clicked so that emails
can be sent.

ave
5 x
Save i workspace v| e
o Debug_Tools
)
ey lipseWork
b——-l e.c ipseWorkspace
Recent Iterns git
MBT_Config
openlRE
[ plugin
Deskinp Practice

svn
tasks
= test

Docurnents | | trapvl.pet

i —
Filesof type: | SNMPv1 Raw file (% pef) = Cancel

|41 Files

SNMEY1 Raw D

]
SHI{Pw3 Raw file (*peted)

Figure 13-5
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2 Open
Look in: workspace e ? - '
Debug_Tools
eclipseWorkspace
Eecent Items ot
MBT_Config
openRE
[ | plugin
Desktop Practice
sn
P tasks
E test
Diocuments
This BC
Wetvork  Files of type: GNPyl Raw file (*pe) - Caucel
1)
SNMPv2 Raw file (¥petvd)
Figure 13-6
Email Alert Z
Email Alert Setting
[] Enable Ermnadl Alert
SMTP Server:
From:
To:
* e comuma ") for multiple recedvers
[T] Authentication [] Enable TLE
Tl aermname:
Pagsweord:
[ oK l [ Cancel
L
Figure 13-7
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Category

There are three SNMPv1 categories including: Sender, Community and Sensor as shown in Figure 13-8.
The Sender page lists all sender IP addresses. The Community page lists all SNMP communities. The
Sensor page lists all sensor types from the traps. Clicking on each category type will act as a filter for all
traps in the traps list. Click the All button to cancel all filters.

Category Al Category Al
=] =]
& 192165310245 # public

# 19216510247

Senderlmmmun'rty Sensor Sender | Community | Sehsor

Category All

Far 4
FaM 3
FaM 2
CPL
FamM 1
FAM S
FaM G
FaM T
FaM G
Irtruzion

Sender Cl:ummun'rtg.fl Sensor |

Figure 13-8

B
iiiiiiiiiié
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There are four SNMPv3 categories including: Sender, Sensor Name, Sensor Type and Username as
shown in Figure 13-9. The Sender page lists all sender IP addresses. The Sensor Name page lists all
Sensor Name from the traps. The Sensor Type page lists all sensor types from the traps. The Username

page lists all username from the traps. Clicking on each category type will act as a filter for all traps in
the traps list. Click the All button to cancel all filters.

Category Al Category an

o 10147.160.7

oo 1014718014

sender Username Senzor Hame
Senzor Type Sensor Namse | zernaime
Cat an

ategory Al
# Components Changed

Senzor Type Sensor Name sender Teermame
sender 1T zername Sensor Type Bensor MName

Figure 13-9
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Once a category has been selected, the filter condition will be displayed at the bottom of the “trap” list.
See Figure 13-10 for reference. As displayed in Figure 13-10, the filter is “Sender = 192.168.10.245,
Community = public, Sensor = CPU 1.” The trap list displays only those traps whose contents are
included in each of the three filters.

Murn Sender Cotrtnunity Sensar Description LocalTimeStarmp

10 19216810245 |public CPUA Upper Mon-critical - going high (20050 001 15:46:22..
11 19216810245 |public CPUA Upper Mon-critical - going high (20050 001 15:46:25..
12 19216810245 [oublic CPUA Upper Critical - going high 200541 0/01 15:46:26...
13 19216810245 |public CPUA Upper Mon-recoversble - goi... (200500001 15:46:26...
20 19216810245 |public CPUA Upper Mor-critical - going high (200500001 15:49:49...
21 19216810245 [oublic CPU A Upper Critical - going high 200541 0/01 15:49:50...
22 19216810245 |public CPUA Upper Mok-recoversble - goi... (200500001 15:49:50...

Sender = 19216810245 | Community = puklic | Senzor = CPL 1

Figure 13-10
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Trap Structure
The Trap Structure displays detailed information for the selected item in the trap list.

SNMPv1 Information includes the “SNMP Header,” “PDU Header”, “PDU Body”, “Bind” and “PET” data
as shown in Figure 13-11.

SNMPv3 Information includes the “SNMP Header”, “Decrypted ScopedPDU”, “PDU Header”, “PDU Body”
and “Bind” data as shown in Figure 13-12.

Trap Structure Trap Structure
| ] SMMP Tragp | SNMP Trap
=l ] SMMP Header B~ | BNMP Header
# Message Length: 125 - # Message Length: 394

. # Mesmge Version: v3
# Message Yersion vi # AuthoritativeEngineID: B0 00 LF 88 80 CE F5 4F 2B 47 CD 1D 61
# Community: public - % AuthoritativeEngineBoots: 267
=l || PDU Header - & AuthoritativeEngine Time: 0
L 3
»
-

® Type: Trap AnthenticationParsmeters: 76 33 23 D2 A3 8F 89 BT FF E7 F1 B9
# length 103 PrivasyParameters: 00 00 01 0B 3D DC 34 CO
® Erterprise: 13,61 41 31831 1 iy ""Decgjgm;’;pz;g‘?
® Agert I 192 16810245 5.1 PDU Header:
& Generic Trap Type: B :
# Specific Trap Type: 262400
® Timeticks : 1126180281 | | FDU Body:
= ;l pOUBOY 1 * TQTBI Length of Variable Binding: 257
# Total Length of Varisble Binding: 72 . gﬁ;
=l |1 Bind

# Length of Binding: 70
& 0D 1361413183111
= || PET Data
& [FAM 3] Lower Mon-critical - gaing [ow
& [0 @ 2w TF] @ [ 0x 0 0x0x

o e P T
S E R R E R ES R R EY)
E

Figure 13-11 Figure 13-12
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Receiving a Trap

When the Trap Receiver receives a trap from the BMC, an alert bar will display on the screen for about
10 seconds to notify you that a trap has occurred. In addition, an email alert will be sent according to the
information field in the Email Alert dialog box. Please refer to Figures 13-13 and 13-14

The SNMPv1 email will include the following information.

A SNMP trap received

Sender:10.147.160.14 (community:public )
Sensor: #0xFF

Description:Event Dir : Assertion

Value: Device @ © CPLD @ 3 Slot @ 5 Ejected
Time:2021/08/31 05:30:56 Tue

i} IPMI Trap Receiver V3.0 (build 210830) - Super Micro Computer, Inc. - O hd
File Help
@ 0 ‘]El & m Q SNMPwl SNMPv3
Start Stop Save Load Clear Email
Category il Wum Sender Community  Sensor Description Local Time? tamp

e 10147 160.14 2 10.147.160.14 [public #1:FF Event Dir : AwertionValue... 202108431 05:31:17 Tue

Bender  Commundty  Sensor

Trap Structure

SHMF Trap ~
= | SNMP Header
- 4 Message Length: 170
- i Mesage Version: vl
- 4 Comrnnity: public
[=--|  PDU Header
Type: Trap
length: 156
Enterprise: 1.2.6.1.4.1.31
AgentIP: 10.147.160.14
Generic Trap Tvpe: 6
Bpecific Trap Type: 1372,
Timeticks: 1630387856
=~ | PDU Body

i @ Tatal Length of Variable |

Bind
i Length of Binding: 6' ¥
>

atrap received
Sender 10147 16014
content: [ DEM] Device @ 0 CPLD @ 3 Slot @ 4 Ejected - As

sssssse

£
a trap received: sender [P =10.147.160.14, content = [ OEM ] Device @ 0 CPLD @ 2 3lot @ 5 Ejected - Asmrbion Finish

Figure 13-13
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The SNMPv3 email will include the following information.

A SNMPv3 trap received

Sender:10.147.160.14 (Username:Derek123 )

Time: 2021/08/30 15:09:56 Mon

Sensor Type:NVMe

Sensor Name:O0EM

Description:Device @ © CPLD @ 3 Slot @ 5 Ejected - Assertion

rap Receiver V3.0 (build 21 - Super Micro Computer, Inc. -
IPMI Trap Receiver V3.0 (build 210830) - S Micro C | O X
File Help
@ 0 E = m @ EHMP1 EN{P 2
Start Stop Save Load Clear Eimadl
Category Al Num Sender LocalTimedt...  Usemame Sensor Type  Sensor Name  Description
1 10.147.160.14 [202108/30 1. |Derekl23 54 TAFaid OEM Dlewicell Y03 .
® 1014716014 2 10.147.160.7  [2021M08/30 1. |Teat OEM 220 40044 46150
& 101471607 2 10.147.160.14 [202108/30 1., |Derskli2 FFE. OEM [EMC] Unaut...
4 10.147.160.14 [2021408/20 1., |Derskli3 NV 1 OEM Device @ 0C...
5 10.147.160.7  [2021M08/30 1. |Test OEM 234 Sustern smart .
Sender Wawems 1 10.147.160.7  [2021M08/30 1. |Teat OEM 234 S vatern srmart ..
S LS Sensor Name 7 10.147.160.14 [202108/30 1., |Derskli2 NV e OEM Dievice @ 0C...
o= SITTHITD atrap received
oo SNMP Trap = Sender: 10.147.160.14
= SHMP Header

@ Mesage Length: 361 content: [ OEM ] Device @ 0 CPLD & 3 Slot (@ 5 Ejected - As

Mesmge Version: w3

-

# SuthoritativeEngimelD: 80 0C
- AuthoritativeEngineBoots: 77
- @ AuthoritativeEngine Time: 0

# AuthenticationP arameters: C9

# PrivacyParameters: 00 00 00
- Username: Derelk123
= | Decrypted Scoped PDU:

= | PDU Header:
4 ContextEngineID: 80 00
@ ConfextName:

= | PDU Body:
w-# Total Length of Variable
= | Bind: W

L4 >
a trap received : sender [P =10.147 160 14, content = [ OEM ] Device @ 0 CPLD @ 3 8lot @ 5 Ejected. - Assertion Finish

Figure 13-14
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14 IPMIView Software Update

To check the latest version of IPMIView, follow these steps.

1. Click Help on the menu bar and then select Check for updates in the pull-down menu (see Figure 14-
1). This will allow IPMIView to check the Supermicro website for a new version.

! IPMIView 2.21.7 (build 230503) - Super Micro Computer, Inc.
File Edit Manage Help

ﬂ HEI|@% E About

Configuration Tip

@ Check for updates...

SUPERMIC

Figure 14-1
2. As shown in Figure 14-2, click Download to start downloading the file to update if a new revision is

available.

# Checking the latest version of [PMIView

SUPERMIC

A new revision(v2.21.2) of IPMIView iz available.
Would vou like to download and install it now?

ot now Download

Figure 14-2

3. When the download is complete, click Open to launch the installation. The IPMIView application will
be closed once you click Yes to continue.

o4
* Downloading the latest version of [PMIView
S.UPERWC Diownloading the new version iz camplete.
Please open the compresed file to finalize the update.

DownloadsUPMI View_2.21.2_buil Coptrnsuon 2
|'@| Closing the IPMIView application is required.
- Do you really want to continue?

ot now Yes
Figure 14-3
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4. Afterwards, note that executing the update file on Windows is different from Linux.
* On Windows: The .exe file is automatically executed to start the installer wizard.

i IPMIView 2.21.2 build 23051, X + - = 23
Mey I} M Sort v = vView v (8 Extractal
« v 4 55> Downloads > IPMView_2.21.2 build.230511_ Windows.zip v G || Search PMiView 2212 bui.. 0
£ Home Name Tupe Compressed size Password .. | Size Ratio
> @ OneDrive - Personal <[ [ IPMIView 2.21.2_build.230511_Windows.exe Application 211,154K8 No
@ Desktop »
workspace »
= Documents #*
<\ Downloads »
Pictures »
) Music »
3 videos »
o tasshare #*
normal_privilege »
report »
SPEC »
& documentation #*

Titem Bll=!

Figure 14-4

®*  On Linux: Extract and execute the file to continue the installation.

IPMIView_2.21.2_build.230511_bundleJRE_Linux_x64.tar.gz

Extract +

< > Location:'h,ﬂ'

Name 4«  Size Type
_IPMIView_Z.21.2_build.23051 1_bundleJRE_Linux_x64 202.5 MB Folder 25 =F 2023, 15:21

Figure 14-5
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Appendix A: SIM Firmware Update

* Select a remote system on the System list and click File> Update IPMI Firmware to start the
firmware update.

Edit Session Manage
Hew ... [
Discover IFMIT Device

Eeload Configuration
Bave Configuration
pdate IFRT Fiomasare

Exit

Figure A-1

* Click the Open button to select the firmware you desire and then click Start to continue.

;j Dpdate Firmware

TP: 192.168.10.24%

Firrmwvare File: | | ’ Open ” Start ]

Me=zage:

Figure A-2
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* Alogin dialog will appear. Please enter the Login_ID and the password. This user will be granted the
privilege as an Administrator.

Please input ID and Password r5_<|

@ Login I ADMM

* Administrator level is required

o

Figure A-3

* A firmware information dialog will appear. It shows detailed information on the current and new
firmware. Click Yes to continue.

Request Confirmation E|

Curresnt firmware

@ Firmuware Version: 1.5.0 build 4238
Firmware Tag: Aug-14-06-17-30
hedware [D: 0x22
CEM: peppercon

Mew firmoware:

Firmware Wersion: 1.5.2 build 4238

Firmware Tag: Aug-16-06-11-10

Firmuware Size: 3092370 bytes

Firmware Path: C:ifw-kira-kimsmigd-smid c-peppercon_040200-4238-081606-1-5-2 bin

Would you like to continue ?

Figure A-4

* The firmware file will start to upload. This process may take few minutes to complete.

IP: 192.168.10.249

srcon_040200-4235-081606-1-5-2 bin |

Firreeare File:

Uploading firmware

Message:

Login to 192.168.10_249
tart firmware upgarde

Mploading firmware _..

Figure A-5
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* Please wait for the firmware to upload. Once uploading is completed, the BMC will start to flash the
firmware internally. This step may take about a minute. Please try to connect to the system after
two minutes.
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Appendix B: SIM(W) KVM Console and
Virtual Media

SIM(W) KVM Console allows the user to perform console redirection via KVM (Keyboard/Video/Mouse)
support as shown in Figure B-1.

1: IPMI Yiew ¥2.7.13 (build 100504) - Super Micro Computer, Inc.
File Edit Session Mansge Help

Bl a g o

SUPERMICR® 1=~

@ @ QIFUHSCIBED E Virtoal Media Soft Keyboard 4fps ] Menu
IPMI Domain =~ & v § £ @&
[ A~

13 12 i Fanl 675.00 RPHM
192.162.12.171
= e 14 13 i Fan2 ©.00 RPM

15 14 | Fan3 0.00 RPM
172.31.143

%1?231.143-1 16 17 i PS Status 0K [00 CO 00 801

1?231.2123 C:N>ipmicfg -sdr >aa

o 172.31.2.145 )

o] 172.31.2.146 C:x>type aa .

5 172.31.1 62 SDR ID i Sensor Sensor Reading

T 17231 231 3 CPUZ Temp nsa [00 EO 07 001

-E_:Eil?231:258 System Temp 36.00 degree C

CPU1 Vcore 12
.00
.31
.23
.81
.86
.23
.23
.80 RPM
.00 RPM
.80 RPM

| 172.31.2.58
oyl 172.31.262
T 172312181
= 10718810118
) 1921681099
= 197 168.10.30
& 1071881050

CPUZ2 Ucore
+12V
+3.3V

i
i
i
i
i
i
i
i DIMM
i
i
i
i
i
i
i

[

+5U
+3.3USH
UBAT
Fanl

T

o
=]
DO WWHA =W

Fan2
Fan3
PS5 Status 0K [06 CO 00 00]

) New Group3 (322)

Redirection ¥iewerstarted...
Login | EventLog | Sensors | [PMIDevice | BMC Setting | Users | Text Console | ¥V Console

RMCP+ Open Sestion successful

Figure B-1 SIM(W) KVM Console Main Screen
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SIM(W) Console Toolbar

The SIM(W) Console Toolbar provides seven tool buttons which will allow the user to perform the
following actions as shown in Figure B-2.

Start Video Redirection

Stop Video Redirection

Screenshot
Refresh (the page)
Full Screen (display)

|
@ Q‘ Full Screen [[] Virtoal Media S-:uftK‘e:.rbuard 1 fps Ehiienu

Soft Keyboard (to use the soft keyboard)
Virtual Media (to use Virtual Media)

Menu

Figure B-2 SIM(W) KVM Console Toolbar
|} Start Video Redirection:
Click this button to start SIM(W) KVM console redirection.
@ Stop Video Redirection:

Click this button to stop video redirection. Please note that the drive redirection will continue to work
when it is enabled.

Full Screen:
| swac]

Click this button to maximize the size of the remote video screen displayed on the local computer screen

as shown in Figure B-3.

Figure B-3 Full Screen
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Virtual Media:

Click this button to enable Virtual Media support as shown in Figure B-4.

“a Yirtual Media

FloppwTT3E Eey Media,

x)

Browse ’ Connect Floppy ]

CD Media

(@ IS0 Tmage
OE
OF

[ e ] [ ComnectCDDYD

Statuz

Target Dirive

Virtual Floppy
Virtnal CD

Connected To Eead Bates

Mot conmnected '
Mot connected nfa

Cloz=

Figure B-4 Virtual Media

*  Floppy/USB key Media: This feature allows the user to redirect Floppy/USB Media.

* CD Media: This feature allows the user to redirect CD/DVD or ISO image file.

* Connect Floppy: Click this button to start to redirect your Floppy Image or USB Key Media.
e Connect CD/DVD: Click this button to start to redirect your CD/DVD or I1SO image file.
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Soft Keyboard:

Click this button to use the Soft Keyboard for console redirection as shown in Figure B-5.

Combination (of Keys) Lock (Hold Modifier Key)

Soft Eeyboard v0.96

Language Modifier KewiCtl, A1, Shift, Win, |PotSe)
(O Single Key

ER( F1 |F2 |F3 |F4 | F5 |Fo |F7 (F8 | F2 |F10|F11|F12 P | Sexl) Pau
“ ol 1 2 3l ] 5 7 ) |- = BR Ins |Hon P MNund |* |-
Tl ol wwa = S v o e 11 ] S| T [ ] Del | End) PDiy Hom & |PUp
Capjil sl =l 1 Gl £ ] ol hualll i i k] ol - ! -+ = = |+
Shift Za -l ol - T i 1 |l Shift it End| § |FDuy
Chl | Wi ATt Alt | Win AppChl = |} |= Inz Del| <

Figure B-5 Soft Keyboard

* Language: This feature allows you to select a proper language setting for your soft keyboard.
* Combination: Check this button if you want to use a combinations of modifier keys.

* Single Key: Check this button if you want to use a modifier key as single key.

*  Lock: Check this button to hold the modifier key you’ve clicked.

The menu is same as web KVM UL.
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Appendix C: SIM (WA) iKVM Console and
Virtual Media

Click Launch KVM Console to open SIM(WA) iKVM Window as in Figure C-1.

:j IPMI Yiew ¥2.7.13 (build 100504) - Super Micro Computer, Inc.

File Edit Zesdon MManage Help

Bl e Ome Rae

SUPERMICR®

L

IPMI Domain = + 9 1t @
| 172.31.262 ~
Tl 172.51.2.181

& 192.168.10.118
& 192.168.10.30
& 192.168.10.50

] 192.168.12.53

21 172.31.2.114

11723111321
=) 192.168.10.174
) 202.128.183.134
=) 192.168.10.168

11723113

2117231136
2172311132 R
lLima 24 amdd o

B New Groupl (2010)
Mew Group2 (27

Mew Group? (322)

I 5 19216812169 | B 19216812125

Conmle Redirection

B Press the button 1o lamnch the redirection consols and mansge the server remotely,

Lamnch KYM Console

| Login | Event Log | Sensors | [PMIDevice | EMC Setting|| Users | Text Console || KM Comscle |

NP+ Open Session suzessstul

Figure C-1 SIM(WA) iKVM Window
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Please note that SIM(WA) iKVM window supports same features as other versions of Web KVM as
shown in Figure C-2.

Jaya iKYM Yiewer v1.55 17 [192.168.12.125] - Resolution 652 X 492 - FPS 0
Virtual Media  Record  Playback  Macro  Cptions  UserList  Ewit

Press any key to enter the menu

Booting Cent0S (Z.6.18-164.e15) in 3 seconds...[]

Figure C-2 iKVM Window

Virtual Media (USB Floppy & Flash)

Click Virtual Media on the menu bar and then click Virtual Storage to display the Virtual Media (USB
Floppy & Flash screen) as shown in Figure C-3.

Virtual Media 1.2 r2

i

TUSE FloppydFlsh | COROM&ISO

Setting for Device 1

Logical Drive Twpe Image Filename and Full Path

|N0 Select v | | | Open Inage
(oo ) [ mew Fog O

Connection Status History

|

[
| £

|

Figure C-3 Virtual Media (USB Floppy & Flash)

Supermicro IPMIView User’s Guide m



* Logical Drive Type: From the pull-down menu select the logical drive type.
* Image Filename and Full Path: Enter the image file name and the full path to the file. It is available

only for ISO files.

* Refresh: Click this button to refresh the page.
¢ Plug In: Click this button to mount your logical drive as virtual media.

¢ Plug Out: Click this button to un-mount virtual media.
*  OK: Click this button to confirm and exit.
¢ Connection Status History: This window displays the connection and the status of virtual media.

Virtual Media (CDROM & 1SO)

Click CDROM & ISO to display the Virtual Media (CDROM & ISO) as shown in Figure C-4.

Yirtual Media 1.2 12

USE Floppy&Flash |

Setting for Device 2
Logical Dirive Twpe
Mo Zelect

Refresh

l

Image Filename and Foll Path
Pagin
Connection Status History
~
v
< >

Figure C-4 Virtual Media (CDROM & 1SO)

* Logical Drive Type: From the pull-down menu select the logical drive type.

* Image Filename and Full Path: Enter the image file name and the full path to the ISO file.

* Refresh: Click this button to refresh the page.

¢ Plug In: Click this button to mount your logical drive as virtual media.

*  Plug Out: Click this button to un-mount virtual media.
*  OK: Click this button to confirm and exit.
* Connection Status History: This window displays the connection and the status of Virtual Media.
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iKVM Virtual Keyboard

Virtual Keyboard provides soft keyboard support and allows the user to click a key on the soft keyboard
by using the mouse when a keyboard is not available. Refer to Figure C-5 for Virtual Keyboard.

Englizh keyboard T||_|r>_(|
esc| |F1|F2|F3|F4| |F5|F6|F7|F8| |[FO|FOFMIF2|  pse slk | pan
1123|4516 |7 Q10 |- |=] =— [fins| | L |fdk|/|* |-
M lgwle ||t |v|uflifo|p]|[]] | Vel | F (| T2 N
JLja|s|d|{f|glh|jlk|1];]']| = - —| |

T lzlx|c|v|b|n|m|,|. |/ 1 T S| L F

ctrl [#¢| alt it &8 o |[<] 4] =|[ s Jael] ™

Figure C-5 Virtual Keyboard
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Appendix D: SIM (W) Firmware Update

2.

1. To re-flash SIM(W) Firmware, select an SIM(W) device, click File on the menu bar and then select
Update firmware in the pull-down menu. A dialog box appears.

Confirmation

- | ) Thiz iz SIM W) device. Pleaze make sure wou have correct fimmware for update (¥ dme)

| OK | Cancel

Figure D-1 SIM(W) Firmware Re-flash

Make sure that you select the correct firmware for update, and click OK. This dialog box appears.
YAFUFlash X
Remote Flash Tool for Hermon/ANM FW V121
IP: 19216812169 | O ptars
[ ] Preserve Bootloader
File: | | [ Browse. .. ]
[ ] Preserve Config Module
Flazh

Figure D-2 YAFU Flash
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3. The selected firmware is checked for validation before remote flashing starts.

Y AFTTFlazh E|
Remote Flash Tool for Hermon/AM FUW 121
IP: |192.15=3.12.1r59 | Options
- : [ ] Preserve Bootloader
Fie: | DAFWAMIETDCT-L_130ima | [ Brows |
[ ] Preserve Confiz Maodule

Mew fiomwsare verson ; 1.30

Figure D-3 YAFU Flash

* |P: This item displays the IP Address of the IPMI device.

* Browse: Enter the file name or browse the data base to select a file that you want to perform
remote flashing.

* Preserve BootLoader: Check this box to preserve the settings of BootLoader.

* Preserve Config Module: Check this box to preserve the settings of Configuration Module.

* Firmware Version: The new firmware version will be displayed.

*  Flash: Click <Flash> to commit the file for remote flashing.

4. Click FW Version. Remote Flashing can only be performed by an Administrator. If you are an
administrator, enter your ID and your password in the dialog box below. Then click OK.

Pleasze input ID) and Password [Z|
9| LoginID | |
\-'Q/ Pazzwrord | |
* A dnindstrator level is requdred,

| ok || Comel |

Figure D-4 ID and Password (Administrator)

5. After you check the firmware versions and click Flash, firmware flashing will start. See the figures
below.
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¥ AFUFlash [z|
Remote Flash Tool for Hermon/aM FW 121
IF: [192.168.12.169 | Options
[ ] Preserve BootLoadex
File: |D:'-.FW'-.AMI'-.K".-‘DCT-L_13EI.hm | [ Browss. . ]
[ ] Preserve Confiz Maodule

Mew fiomwsare verson ; 1.30

Current firmeeare versiomn: 1,30

Y AFIFlazh

Remote Flash Tool for Hermomn/AM FUW 1231

Figure D-5 Display of Current Firmware Version

3

IF: |192.168.12.169

| Ciptions

Prezerve Bootl.oader

File: |D:'-.FW'-.AMI'-.}{?DCT-L_13III.iJm| Browss. .

Preserve Config Module
Wew firmware verson : 1.30
Crrrent firmevare version: 1.30 FW Version
statuz 79 (1,310,720 bortes £ 16,777,216 botes )
1T |
Femaining Time: 6 minfs) 47 mels) Flach

Figure D-6 Remote Flash #1
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YAFUFlash ['5_<|
Remote Flash Tool for Hermon/AM FW V121
IF: |192.168.12.169 | Oiptinns

Presrve Bootl oader

File: |D:\FW\AMI‘\K?DCT-L_13EI.m| Browse...

Preserve Config Moduls
Wew firmyeare version : 1.30
Crrent firmware verson: 1.30 FW Version
Status: 22% ( 2,801,088 bydes /16,777,216 bytes )
LLLLLLLL L]
Remaining Time: 5 miniz) 41 sec(z) Flazh

Figure D-7 Remote Flash Screen #2

Y AFOFlash &|
Remote Flash Tool for Hermon/AM FW w121
IF: 119216812 169 | Oiptions

Preserve Bootloader

Fils: |D:\FW\AMI‘\K?DCT-L_13EI.m| Browse...

Preserve Config Moduole
Wew finmueare wersion : 1.30
Crrent firmware versdon: 1.30 FW Version
Status: 51% (8,585,216 bytes / 16,777,216 bytes )
LB b bbb bbbl
Remaining Time: 3 min(z) 35 sec(s) Flazh

Figure D-8 Remote Flash Screen #3

6. When the flashing is complete, the status field displays “Finished.” Click Finish to exit this dialog box.

Y AFFlash &|
Remote Flash Tool for Hermon/AM FW Vi1
IF: |192.168.12.169 | Options

Preserve BootLoader

File: |D:\FW\AMI\K?DCT—L_IBD.m| Browse...

Preserve Config Module
Mew firmusare version : 1.30

Crurrent firmevare version: 1.30 FW Verson

Status: Findshed, (BMC needs 1 minvte to restart)

IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIlllllllllllllllllllllq

Figure D-9 Remote Flash Screen #4
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Appendix E: SIM (WA) Firmware Update

1. To re-flash SIM(WA) Firmware, select an SIM(WA) device, click File on the menu bar and then select
Update firmware in the pull-down menu. A dialog box appears.

Confirmation

- | ) This is SIM{WAY device. Please make sure you have corect firmware for update (* bin)

ok ][ comcel |

Figure E-1 Firmware Update

2. Make sure that you have the correct firmware for the update and click OK. The dialog box below
appears.

Flazh Tool rs_(|

Remote Flash Tool for Hermon/AT FW ¥1.20

IF: |192.168.12.125 |
|

File: |

Browse...

Figure E-2 Flash

3. Click Browse to select the desired firmware file for remote flashing. It will be checked for validation
before remote flashing starts.

Flash Tool rs_<|

Remote Flash Tool for Hermon/AT FW w120

IF: |192.168.12.125 |

File: |D:\FW\ATEN\X8DTL_81?.bin |

Hew firmuware version : 01.15

Figure E-3 Flash

Supermicro IPMIView User’s Guide m



4. Click FW Version. Remote flashing can only be performed by an administrator. If you are an
administrator, enter your ID and password in the dialog box.

Please input 1IN and Password

2 wen [

* Ldyndnistrator level iz reguined

[ ok ][ Comel |

Figure E-4 ID/Password

5. After you check the firmware version and click Flash, firmware flashing will start.

Flazh Tool gl

Remote Flash Tool for Hermon/AT FW ¥1.20

IF: |192.153.12_125 |

File: |D:\FW\ATEI-I\XBDTL_81?.hm

Mews fimmware verson ; 01.15

Current firmware version: 01,10

Figure E-5 Firmware Versions

Flazh Tool

x]

Remote Flash Tool for Hermon/AT FW ¥1.20

IF: |192.153.12_125 |

File: |D:\FW\ATEI'I\X8DTL_81?.hm | Browse...

Blew firmware wersion - 01.15
Current firmware version: 01.10 FW Verson

Statuz Uploading. ..

0%

Figure E-6 Remote Flash #1
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Flazh Tool

X

Remote Flash Tool for Hermon/AT FW ¥120

IF: |192_153_12.125 |

File: |D:\FW\ATEN\X8DTL_81?.bm | Browse. .

WNew fimmmware version : 01.15

Current firmvware version: 01.10 FW Version

Statuz: Updating. ..

- T

Figure E-7 Remote Flash #2

Flazh Tool

K

Remote Flash Tool for Hermon/AT FW ¥12.0

IF: |192.158.12.125 |

File: |D:\FW'\ATEN\X8DTL_81?.bm | Browse. .

WNew firmware version : 01.15

Current firmware version: 01.10 FW Version

Status: Updating. ..

Figure E-8 Remote Flash #3
6. When the flashing is complete, the status field displays “Finished.” Click Close to exit this dialog box.

Flazh Tool r§_<|

Remaote Flash Tool for Hermon/AT FW ¥1.20

IF: |192.153.12.125 |

File: |D:\FW\ATEN\X8DTL_81?.bin | Browss...

Wew firmware version : 01.15
Current firmeare version: 01,10 FW Version

Statug: Finished

100%

Clos

Figure E-9 Remote Flash #4
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Appendix F: ASPEED X10 Firmware Update

1. To re-flash ASPEED Firmware, select an ASPEED BMC device, click File on the menu bar and then
select Update firmware in the pull-down menu. The dialog box below appears.

Confirmation &J
‘0‘ This is ASPEED BMIC. Please make sure you have correct firmware for update (*.bin,32M size)

Figure F-1 Firmware Update

2. Make sure that you have the correct firmware for the update and click OK. The dialog box below
appears.

Flash Tool &J

Remote Flash Tool for Hermon ASPEEDIAT FW ¥1.30

P 101321770

Status: Preserve Config

Figure F-2 Flash

3. Click Browse to select the desired firmware file for remote flashing. It will be checked for valication
before remote flashing starts.

Flash Tool l&]

Remote Flash Tool for Hermon ASPEEDIAT FW Y120

P 101321770

File:  |(CASMT_X10_105 bin

Wew finmueare version : 1.5

Satuz: Preserve Config

Figure F-3 Flash
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4. Click FW Version. Remote flashing can only be performed by an administrator. If you are an

administrator, enter your ID and password in the dialog box. Then click OK.

-
Please input ID and Password

S5)

LoginID ADMIN

Password [ 1111 )
* B dmindstrator level is required

[ ok || cancel |

Figure F-4 ID/Password

5. After you check the firmware versions and click Flash, firmware flashing will start.

Flash Tool léj
Remote Flash Tool for Hermon ASPEEDIAT FWW Y130
B 101331770
File: |CASMT_Z10_105 bin
Hew firmueare versdon : 1.5
Current firmyware version: 01.04
Satus: Preserve Config

Figure F-5 Firmware Versions

6. When the flashing is complete, the status field displays “Done.” Note that it takes one minute for

the BMC to restart. Click Close to exit this dialog box.

[ Flash Tool &Jw
Remote Flash Tool for Hermon, ASPEEDIAT FW ¥1.:0
P2 101321770
File: |CA3MT_H10_105bin Birovwse..
Hew finmware verson : 1.5
Current firmware version: 01.04 FW Version
Statuz: Done. (EMC needs 1 mdnte to mestart) Preserve Config

Figure F-6 Remote Flash
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Appendix G: ASPEED X12 Firmware
Update

1. To re-flash ASPEED firmware, select an ASPEED BMC device, click File on the menu bar and then
select Update Firmware in the pull-down menu. The dialog box below appears.

Cenfirmation X

‘03 This is a X12 AST2600RoT BMC device. Please make sure you have correct firmware for update(*.bin,32M size)

Ganca

Figure G-1

2. Make sure that you have the correct firmware for the update, and click OK. The dialog box below
appears.

Remote RedFish Flash Tool

Information
IP: 10.147.160.34
Current Firmware version:
Firmuware image version:
File: Browse
Options |
Preserve CFG ‘
Preserve SDR
Preserve SSL

[] Backup image ‘

| Ready

Flash Cancel

Figure G-2
3. Click Browse to select the desired firmware file for remote flashing. It will be checked for valication
before remote flashing starts.

Information
IF: 10.147.160.34

Current Firmware version: Q

Firmuware image version: 0.1082

File: Diresources\FWAX 12DPU_AST2600WMT Browse

Options |
Preserve CFG ‘
Preserve SDR
Preserve SSL

[[] Backup image ‘

| Checkfile ... Done

Flash Cancel

Figure G-3
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4. Click the check icon &, . Remote flashing can only be performed by an administrator. If you are
an administrator, enter your ID and password in the dialog box. Then click OK.

’ ‘e} Login ID ADMIN

== Password 0000

* Administrator level is required
Figure G-4

5. After you check the firmware versions and click Flash, firmware flashing will start.

Information
Ip: 10.147.160.34
Cuurent Firmware version: 0.10.82 @%
Firmuare image version: 0.1082
File: Dresovrces\FWAK12DPU_AST26008MT Browss
Options

Prese

ve CFG

Preserve SDR
Preserve SSL
Backup image

Flash Cancel

Figure G-5

6. When the flashing is complete, the status field displays “Device is ready now.” Note that it takes a
few minutes for the BMC to restart. Click Cancel to exit this dialog box.

Information

IP: 10.147.160.34

Current Firmware version:  0.10.82

Firmuware image version: 01082

File: Di\resources\FW12DPU_AST2600\SMT_ Browss
Options

Preserve CFG

Preserve SDR

Preserve SSL

[[] Backup image

Device is ready now.

100%

Flash Cancel

Figure G-6
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Appendix H: Updating ASPEED X12 BIOS

1. To re-flash ASPEED BIOS, select an ASPEED BMC device, click File on the menu bar and then select
Update BIOS in the pull-down menu. The dialog box below appears.

Remote RedFish Flash Tool

Information

IP: 10.147.160.34

Curzent BIOS version: @

BIOS image version:

File: Browse
Options ‘

[ Preserve ME

Preserve NVRAM

Preserve SMBIOS

[[] Backup image ‘

| Ready ‘

Flash Cancel
Figure H-1

2. Click the check icon & . Remote flashing can only be performed by an administrator. If you are an
administrator, enter your ID and password in the dialog box. Then click OK.
[please inout 1D and Paseword X.

% LozinID ADMIN
" Password sssee

* A dministrator level is required

Cancel
Figure H-2

3. Click Browse to select the desired firmware file for remote flashing. It will be checked for validation
before remote flashing starts.

IF: 10.147.160.34

Current BIOS version: 1100842020 Rev 1.0 @,

BIOS image version: 1140812020 Rev 1.0

File: D resources\FW12DPU_AST26008BI0SY | Browse
Options

Preserve ME

Preserve NVRAM

Preserve SMEIOS

[[] Backup image
Check file ... Done

Flash Cancel
Figure H-3
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4. After you select the firmware file, click Flash. firmware flashing will start.

Information
IF: 10.147.160.34
Current BIOS version: 11/08/2020 Rev 1.0 Q
BIOS image version: 11/08/2020 Rev 1.0
File: Dhresovrces\FWAK 1 2DPU_AST2600ABIOSY Browse
Options
Preserve ME

Preserve NVRAM

Preserve SMBIOS

Backup image

Flash Cancel

Figure H-4

5. After the flashing is complete, the status field displays “Device is ready now.” Note that it takes a
few minutes for the BMC to restart. ” Click Cancel to exit the dialog box.

Information
Ip: 10.147.160.34
Current BIO version: 11/08/2020 Rev 1.0 @,
BIOS image version: 11/08/2020 Rev 1.0
File: D:resources\FWW12DPU_AS TESUU\BIOS\ Browse
Options
Preserve ME
Preserve NVRAM
Preserve SMBIOS
[] Backup image
Device is ready now. |
Flash Cancel ‘

Figure H-5
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Appendix I: Node Product Key Functions

The node product key, including SFT-OOB-LIC and SFT-DCMS-Single, provides the following functions:
Functions requiring SFT-OOB-LIC (or SFT-DCMS-Single):

) Virtual Media

Functions requiring SFT-DCMS-Single

. KVM Console (HTMLS5)
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Appendix J: Stunnel Properties

When using the iKVM Console, a Stunnel proxy is used to establish an encrypted connection. The first
non-loopback IP address by default is used for a UNIX system. You can change your own NIC IP address
by setting the “proxy_ip” in the stunnel.properties file.

proxy_ip=

"stunnel.properties™ 1L, 17C

Supermicro IPMIView User’s Guide



Appendix K: Q&A

Q: Why can’tI save a configuration/open KVM

window on Windows platform?

A: There are two ways to solve this problem:

Running the IPMIView using the Administrator permission

a. Right-click the IPMIView20 icon, click More and then click Run as administrator.

b. When prompted for an administrator password or for a confirmation, type the
administrator password, and click Continue.

— Recently added Windows Server

3P TrapReceiver

20 1PMIView20 5 é

=3 Pin to Start

< findows Windows
| Uninstall More S
-3 Pin to taskbar

Most used Uninstall =
Run as a different user

'i) Firefox ‘i
Windows
&8 Snipping Tool Administrativ... 1

Run as administrator
Open file location

“*~1 Command Prompt Remove from this list

d Paint % X Clear list

e Intenet Explorer Event Viewer File Explorer

Installing the IPMIView to another location
Select a drive other than C drive. However, when you install the IPMIView, do not install it
to the default path (C:\Program Files).

Q: How can I enable automatic log monitoring in

IPMIView?

A: Open a Command Prompt and change directory to the IPMIView folder and run the command

“java -jar IPMIView20.jar d” to enable automatic log monitoring. A log.txt file is then created
and saved in the IPMIView folder.
Note: The log size grows rapidly if the transaction is busy.
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Q: Why does a permission error appear when I
install Supermicro on Windows?

A: Please execute the installation in the “Run as administrator” mode because some IPMIView
functions require OS write permission.

Q: Why can’tI launch IPMIView after installation?

A: To start the IPMIView for the first time, please execute it as an Administrator.
1. Right-click the IPMIView20 icon, click More and then click Run as administrator.
2. When a dialog box appears and asks for an administrator password, type the
administrator password, and click Continue.

Q: Why does my Trap Receiver icon become %7

A: It indicates that the IPMIView cannot receive any traps. Please check your network, firewall
or operating system settings.

Q: Why do texts or icons in the dialog boxes or
windows appear incomplete?

A: The partially displayed dialog boxes or windows (see the exemplary figures below) result
from your system's scaling settings.

=] Add a new system...

Sysre — >
IP address” 0.0.0.0 e Request Confirmation

Description: | DESCRIPTION Save changes to configuration?

No Cancel

To fix the problem, open Start Menu, select Settings>System>Display, and then set the scaling
in the Change the size of text, apps, and other items field to be 100%.
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Appendix L: Supported BMC List

ASPEED AST2600 BMC on-Board (e.g. X12DPU, X12DPi boards)

ASPEED AST2500 BMC on-Board (e.g., X11SPL-F, X11DPU, X11DGQ, B11DPT boards)
ASPEED AST2400 BMC on-Board (e.g., X10, X11SSH-F, B10, B1 boards)

Renesas SH7757 BMC on-Board (e.g., X9, B9 boards)

Nuvoton WPCM450 BMC on-Board (e.g., X9 boards)

Winbond WPCM450 BMC on-Board (e.g., X8 boards)

* KVM-over-LAN supports BMCs with ATEN solution in ASPEED AST2500 (e.g., X11, B11), AST2400 (e.g.,
X10, B10, B1) and WPCM450 (e.g., X9)
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Appendix M: Third-Party Software

The following open source libraries are used in IPMIView package.

Library License
AbsolutelLayout Apache 2.0
Miglayout BSD
Jfreechart LGPL
Jackson Apache 2.0
openssl OpenSSL
run-as-root Apache 2.0
out-process Apache 2.0
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Contacting Supermicro

Headquarters

Address: Super Micro Computer, Inc.
980 Rock Ave.
San Jose, CA 95131 U.S.A.

Tel: +1 (408) 503-8000

Fax: +1 (408) 503-8008

Email: marketing@supermicro.com (General Information)
Sales-USA@supermicro.com (Sales Inquiries)
Government_Sales-USA@supermicro.com (Gov. Sales Inquiries)
support@supermicro.com (Technical Support)
RMA@supermicro.com (RMA Support)

Website: WWW.supermicro.com

Europe

Address: Super Micro Computer B.V.
Het Sterrenbeeld 28, 5215 ML
's-Hertogenbosch, The Netherlands

Tel: +31 (0) 73-6400390

Fax: +31 (0) 73-6416525

Email: Sales_Europe@supermicro.com (Sales Inquiries)
Support_Europe@supermicro.com (Technical Support)
RMA_Europe@supermicro.com (RMA Support)

Website: www.supermicro.nl

Asia-Pacific

Address: Super Micro Computer, Inc.
3F, No. 150, Jian 1st Rd.
Zhonghe Dist., New Taipei City 235
Taiwan (R.0.C)

Tel: +886-(2) 8226-3990

Fax: +886-(2) 8226-3992

Email: Sales-Asia@supermicro.com.tw (Sales Inquiries)
Support@supermicro.com.tw (Technical Support)
RMA@supermicro.com.tw (RMA Support)

Website: www.supermicro.com.tw
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